Jump to content
bramwolf

Selectfield values from Form to Page fields randomly refusing to save

Recommended Posts

Hey Guys!

I ran into some really strange behavior when trying to save selected Selectfieldtype values

from a form to a select field in a page. I have three different dropdowns in this page, all

with different values and they randomly get saved en sometimes they don't. 

This is my setup:

Form                                                       Page:

Dropdown a:                                           Dropdown a:

-                                                               - V

-                                                               -

- V                                                            -

Dropdown b:                                           Dropdown b:

-                                                               - V

-                                                               -

- V                                                            -

Dropdown c:                                            Dropdown c:

-                                                               -V

-                                                               -

- V                                                            -

I have no idea what is causing this since it happens completely randomly,

does anybody have any ideas? Like, would it make more sense to only use

a text field on the page side to recieve the value? and if so, why?

Thanks in advance :)

Gr,

Bram

PS: In the screenshot you can see the three filters that pick up the dropdown values and

show the entries that are equal to the filter. And you can see the dropped values in the

submissions.

post-2187-0-36817100-1458124288_thumb.pn

Share this post


Link to post
Share on other sites

The select fields I was using on the page seemed to want to use a single non-spacing term of word as a identiefier object,

and the second as value. I only inserted one value per line, with breaks, and those were the ones that did not work.

I solved this by changing the fields on my page to text fields which contain the value supplied by the select field from the

form. And I think I could have doen it by inserting the value after for example: 1:=Value One.

Hope this might help somebody one day :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By 999design
      Hi all,
      Running into an odd error that I can't seem to get my head around.
      We have 2 separately created Formbuilder forms sitting on a single page.
      But we keep experiencing weird results with them, originally we couldn't get one of the forms to ever submit so we ended up disabling CSRF for them which let us get around this issue.
      However it then causes a problem in that with CSRF disabled, one of forms always records 2 entries on submission. Just a straight duplicate within the entries for that form.
      So trying to stop this happening we tried enabling CSRF again and although that does stop the duplicated entry, it ends up giving really weird feedback such as the attached screengrab.
      Hazarding a guess I assume whatever is trigger on submission is firing twice because of the presence of the second form, but I have no idea why this would be the case as they are 2 seperately named forms?
      Any ideas?

    • By cosmicsafari
      Hi all,
      I have the same form on multiple pages, the idea being that I can populated a hidden field with a page specific value automatically.
      I figured this should be reasonably straight forward but I can't seem to get the following to take effect.
      <?php echo $forms->embed ('my-form-name', array('hidden_field_name' => '666')); ?> No matter what I do, it never updates the default value currently set for said hidden field.
      Feels like I'm missing something really obvious?
      Any ideas?
    • By benbyf
      I have a a form in my site footer that can be accessed anywhere on site, I've added the form in the _inc.php file and added the render in the pages footer.php. However, this works well on the homepage e.g. you can submit said form and get a thank you on reload, doesnt work at all on other pages... Just lots like a fresh reload. Any thing im doing wrong here or ways to diagnose as there isn't an error log for formbuilder etc...?
    • By neophron
      Hi,
      I hope, this is the right place for questions about the Formbuilder (I couldn't find in the ProField support a subsection for the Formbuilder).
      A client needs for his website a random generator of a code (as winning numbers). This generator should be placed in a simple form (name and email) and a random generated code should be visible there.
      This code, or winning number, must be stored in the db together with the name and email. And the participant must receive a confirmation email with this code.
      I know, that the Formbuilder can store and send data to the user. But what about a random generated code? Is this a hook job?
      I found this module: http://modules.processwire.com/modules/process-field-generator/ but it's not for PW 3. 
    • By prestoav
      Hi folks.
      I'm building a Formbuilder form to create new advert pages in a marketplace. Formbuilder is ideal for this. I need to add a description field that allows text to be added with line breaks etc. so showing a CKEditor field would be ideal (i.e. exactly like the field I'm typing into right now)!.
      Does anyone know if it's possible to add a CKEditor field to the front end presentation fo a Formbuilder field, maybe via a module or such?
      Many thanks!
×
×
  • Create New...