Jump to content

Tracy Debugger


adrian

Recommended Posts

3 minutes ago, kongondo said:

@adrian. Is this currently possible though? Are you saying it is possible for ProcessWire to detect which modules are helper/child modules?

I don't think it is possible - that's the main problem - I think it should be possible to tag these modules as such. It's the main reason why my ModuleToolkit module was never officially released because there were things I just couldn't do because of this lack of properly defined relationship between modules.

Link to comment
Share on other sites

2 minutes ago, MarkE said:

Any idea why, in the console, I get this message "Invalid argument supplied for foreach()" in lines 172, 180 and 184 of CodeProcessor.php?

Those all are asking for $session via AJAX, so it looks like for some reason that is not passing through. Is it just on one PW install, or are you seeing this more widely? Can you narrow it down to something that might be server specific?

Link to comment
Share on other sites

Hi @MarkE - I don't think there is anything I can do at my end to fix this, but I am curious what "multi install" setup you are using. I wonder if you could confirm that you are having issues with $session / $page with AJAX calls in general and see if you can figure out a solution for that.

Link to comment
Share on other sites

  • 4 weeks later...

Hi everyone,

I have released a few PHP 8 fixes over the last week or so, but today's was the biggest with an update to the Adminer core. Unfortunately the automatic login feature of Adminer seems to have been broken for quite some time now, which is why I haven't upgraded it in a while, but now with the need to support PHP 8, I didn't really have much choice. I have managed to implement a hacky way to make the automatic login still work but I'd appreciate feedback on whether you are having any problems with this please.

I have of course contacted the Adminer developer about the issue (via the forum because there is no Github issues option 😞 ) but it's been mentioned by others as well, so not sure what's going on. Anyway, hopefully my hacky way will be seamless enough.

PS - not sure what others think, but the context aware Adminer panel is one of the features I use most in Tracy.

  • Like 6
Link to comment
Share on other sites

  • 2 weeks later...
11 minutes ago, LAPS said:

Well it sounds like that is a useful thing for it to alert you to 🙂  - if you take a look at the RepeaterMatrixPage.php file, you'll see that the render() method isn't hookable.

Perhaps You are probably looking for InputfieldRepeaterMatrix::render

 

Link to comment
Share on other sites

@adrian I don't know if you've access to the linked topic in my previous post, but I'm not using any hook for RepeaterMatrix nor InputfieldRepeaterMatrix.

The error with RepeaterMatrix occurs when Tracy Debugger is enabled and it doesn't occur when Tracy Debugger is disabled.

Could be this a bug?

Link to comment
Share on other sites

@LAPS - the error originates here: https://github.com/processwire/processwire/blob/d8945198f4a6a60dab23bd0462e8a6285369dcb9/wire/core/WireHooks.php#L520

I just checked out that other post - I don't think it's an issue with Tracy, but I'd appreciate it if you could try disabling all panels in the panel selector and see it that makes a difference. If it does, can you narrow things down to a particular panel for me? 

I'm also curious if it might be related to the latest Tracy core update. Could you try forcing 2.7.x by modifying this line: https://github.com/adrianbj/TracyDebugger/blob/94047302d6ffe3e933ee7d8eaf9514c192f2c50d/TracyDebugger.module.php#L333 so that it loads 2.7.x - be sure to hard reload the browser to flush the cache.

Let me know if either of those help.

Link to comment
Share on other sites

3 minutes ago, adrian said:

I just checked out that other post - I don't think it's an issue with Tracy, but I'd appreciate it if you could try disabling all panels in the panel selector and see it that makes a difference. If it does, can you narrow things down to a particular panel for me? 

In Admin > Modules > Tracy Debugger, I checked "Enable Tracy Debugger". Then, in front-end, I clicked the button TracyDebugger01.png.6ef82615341a4df98c3bcbcdad1f96af.png so to have this Tracy Debugger panel TracyDebugger02.png.2aac1816fc4cd2573ca5575c0a8899b1.png. When I click a link for downloading a file the error is still generated.

9 minutes ago, adrian said:

I'm also curious if it might be related to the latest Tracy core update. Could you try forcing 2.7.x by modifying this line: https://github.com/adrianbj/TracyDebugger/blob/94047302d6ffe3e933ee7d8eaf9514c192f2c50d/TracyDebugger.module.php#L333 so that it loads 2.7.x - be sure to hard reload the browser to flush the cache.

How should I change the code line?

Link to comment
Share on other sites

Around line 333 I've the following code:

// load Tracy files and our helper files
$tracyVersion = version_compare(PHP_VERSION, '7.1.0', '>=') ? '2.7.x' : '2.5.x';
require_once __DIR__ . '/tracy-'.$tracyVersion.'/src/tracy.php';
require_once __DIR__ . '/includes/TD.php';
if($this->data['enableShortcutMethods']) {
  require_once __DIR__ . '/includes/ShortcutMethods.php';
}

Probably I'm not using the latest Tracy core update.

Link to comment
Share on other sites

Just now, LAPS said:

Around line 333 I've the following code:


// load Tracy files and our helper files
$tracyVersion = version_compare(PHP_VERSION, '7.1.0', '>=') ? '2.7.x' : '2.5.x';
require_once __DIR__ . '/tracy-'.$tracyVersion.'/src/tracy.php';
require_once __DIR__ . '/includes/TD.php';
if($this->data['enableShortcutMethods']) {
  require_once __DIR__ . '/includes/ShortcutMethods.php';
}

Probably I'm not using the latest Tracy core update.

Ok, so what version are you using?

Link to comment
Share on other sites

Just now, LAPS said:

v4.21.30 (as wrote in the linked post😉

Ok, sorry - I missed that.

If you are running php 7.2+ it might be worth updating to the latest version of Tracy, although I don't really expect it will help.

I am running out of ideas here, but perhaps you could try putting Tracy into strict mode to see if it provides a full stack trace of the error.

Link to comment
Share on other sites

11 minutes ago, adrian said:

If you are running php 7.2+ it might be worth updating to the latest version of Tracy, although I don't really expect it will help.

I upgraded to Tracy v4.21.33 and confirm the problem still occurs. I had to disable Tracy to solve it.

 

Link to comment
Share on other sites

@LAPS - the other thing to try is to enable PW debug mode (if it's not already). I have a feeling that with Tracy disabled and debug enabled, you'll probably see that error again. I don't know where the error is coming from, but I don't think it's Tracy - Tracy is likely just reporting it whereas otherwise it's going hidden and therefore not affecting the download.

Link to comment
Share on other sites

  • adrian pinned and locked this topic
  • adrian unpinned and pinned this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...