Jump to content

Suddenly i am not able to edit fields or delete images in home-page (root page)


Recommended Posts


i don't understand why this problem only appears when im trying to edit the root page (home).

All subpages are working.

I made a video of the problem: Video

My boss made an update yesterday from php version 5.3.29 to 5.6.17-1~he.2 (At the moment i am not able to downgrade the version)

Maybe this is the reason?

My Processwire Version: 2.7.2



MySQL-Version (phpinfo();)


Link to comment
Share on other sites

I don't think that the PHP version is the culprit - I have 5.6.17 as well, and it works. Did you check the file permissions, especially the site/assets/files/1 directory?

The permissions are ok (755) - processwire is able to upload into this folder

i have also the debugger set to "true". I am not getting any errors while i am trying to edit the root-page.... and Tracy Debugger is for Version 3

I think i will reinstall Processwire....

Link to comment
Share on other sites

i have also tried to configure suhosin values:

php_value suhosin.get.max_array_depth 1500
php_value suhosin.get.max_array_index_length 1536
php_value suhosin.get.max_name_length 768
php_value suhosin.get.max_totalname_length 1536
php_value suhosin.get.max_value_length 3072
php_value suhosin.get.max_vars 6144
php_value suhosin.post.max_array_depth 1200
php_value suhosin.post.max_array_index_length 768
php_value suhosin.post.max_name_length 768
php_value suhosin.post.max_totalname_length 1536
php_value suhosin.post.max_value_length 195000
php_value suhosin.post.max_vars 6144
php_value suhosin.request.max_array_depth 300
php_value suhosin.request.max_array_index_length 768
php_value suhosin.request.max_name_length 768
php_value suhosin.request.max_totalname_length 1536
php_value suhosin.request.max_value_length 195000
php_value suhosin.request.max_varname_length 768
php_value suhosin.request.max_vars 6144
php_value suhosin.cookie.max_array_depth 1200
php_value suhosin.cookie.max_array_index_length 768
php_value suhosin.cookie.max_name_length 768
php_value suhosin.cookie.max_totalname_length 1536
php_value suhosin.cookie.max_value_length 60000
php_value suhosin.cookie.max_vars 6144
php_value suhosin.memory_limit 512M

it doesnt work... I'm totally despairing right now... am i the only one with this special problem? I have also moved the whole project to another server without suhosin...i get the same error! What is wrong?

Link to comment
Share on other sites

I still doubt that it has to do with your PHP setup. What does happen if you try to duplicate the root page? Does the copy show the same problem?

I am not able to duplicate the Root-Page (i mean with the same template called "home"). I have only created an subpage with a new template-file called "intro" (which is the copy of the home-template) but this is only an avoidance not a real solution


Link to comment
Share on other sites

Before you duplicate "home" you have to change the "Can this template be used for new pages?" option in the home template's family settings, as it's set to "no" by default.

i have set it to "yes" but i am still not able to duplicate the root-page

Sry i am able to create a new subpage with the "home"-template  .... every change is recognized by the server/processwire....this is really strange!!!

I don't get it... Only the root-page has this strange behavior :(

Link to comment
Share on other sites

  • 9 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...