Jump to content

One single Permission per Process, Permission Wildcards


kixe
 Share

Recommended Posts

The triumvirate of user, role and permission with endless configuration possibilities is one of many features that I appreciate about ProcessWire. Unfortunately, this system is not really consistent.

In a pilot project, a private carsharing page I use ProcessWire exclusively with the backend. All features (calendar, parking marker, dialog) are modules (processes).
It was a bit tedious to control the accessibility of certain areas in the Admin. e.g. page search, ProcessPageList SettingsTab, Show/ Hide page tree. I managed most with hooks.

It would be much easier if every feature (process class) has its own permission.
To obtain maximum configuration options, while keeping clarity, each process module should have an intrinsically Permission. Permissions can be grouped, for example, as parent / child permission (pages) or via wildcards page- * (implements page-edit-*, page-delete), page-edit-* (implements page-edit-access page-edit), page-edit-access etc.

This would be an important step towards Application Framework.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By jonatan
      "Permission “page-sort” for template “ ... ” not allowed (requires “page-edit” permission)"

      – This lovely error message is thrown at me, if, as implied by it, I try to add (to my "editor" role) the permission "page-sort" for a specific template, without the permission "page-edit" enabled for the same template.
      Seems like it's been mentioned a few times before but never properly answered, by e.g. @Robin S ... :  
      "Allow the granting of page-sort permission independent of page-edit": https://github.com/processwire/processwire-requests/issues/29
       
       
       


      Why do I wanna do this?:

      I have a page tree structure  🌳  as so:

      ________________________

      Category [C1]
      – Page a [C1_p] – Page b [C1_p] Different category [C2]
      – Page c [C2_p] – Page d [C2_p] ________________________

      The page "Category" has the page-template "C1",
      the pages "Page a" and "Page b" both have the page-template "C1_p".
      The page "Different category" has the page-template "C2"
      the pages "Page c" and "Page d" both have the page-template "C2_p".
       
      The two pages called "Category" and "Different category" do not have any content, they only serve as containers for pages belonging to that category.
       
      I want my "editor" role not to be able to do anything at all with these pages "Category" and "Different category"; i.e. I do not want my editor to be able to edit, move, unpublish, hide, lock, delete (or do anything else to) these category pages. 
      – So, I want my "editor" role to have the "page-edit" permission for pages with the templates "C1_p" and "C2_p", but not for the pages with the category templates "C1" and "C2",
      Also, I want my "editor" role to be able to move the pages with the templates "C1_p" and "C2_p" within their parent-pages. 


      Problem:

      But if I just simply add the "page-edit" and the "page-move" permissions for the "C1_p" and "C2_p" templates, then, using the "editor" role, I am not able to move these "C1_p" (and "C2_p") -template-based pages. I can actually click "MOVE" next to them and then move them, but... then I will be met by the error message "You do not have permission to sort pages using this parent - /Category/".  
      – So, I try to add the "page-sort" (description: "permission to sort child pages") permission to the "C1" and "C2" templates... but then trying to do so I am met by the initially mentioned error message   ! Permission “page-sort” for template “C1” not allowed (requires “page-edit” permission)  . 
      And, as mentioned, I do not want my editor role users to be able to edit these category ("C1" and "C2") pages...
      – what to do about this? 😅 
       
      All the best,
      Jonatan 
    • By AndZyk
      Hello,
      I have a user role employee with the permission page-edit-created. This user role has access to add new pages to the template posts with the template post.
      The template posts should have children with the template post. The template post should have the parent with the template posts. Now every time I try to add a new page with the template post, an exception throws:
      You don't have access to the template required to add pages here
      Is this a bug in this permission or have I not configured the permissions correct?
      Is there a hook to allow to add pages to the template posts for the role employee?
      I would appreciate some help. 😀
      Regards, Andreas
    • By Slideth
      Hi! I am new to processwire and really like working with it so far.
      For a relaunch project, some editors of our website need the permission to add redirect URLs while migrating the content. I already created a role "site-manager" so only a few team members have access to certain features.
      There is also the option to add redirect URLs in the page settings, but it seems to be restricted only to superusers. Does anyone know of a way to grant permission for this option to another user role?
      Since this is the first PW-Project I did not dive in too deep with the permissions yet. I also tried to add a "page-edit-redirect"-permission, but I am somehow stuck on what to do with it.
      Thanks
    • By AAD Web Team
      Hi,
      I've put in a support request (as a followup on an existing one) for this but it's nearly 10pm Ryan's time, so I thought I'd ask on here just in case someone can help...
      Yesterday we purchased ProDrafts, but I couldn't get the key to validate. Every time I hit submit on the module settings screen the key would be removed from the field I entered it in, and then it would complain about the missing value. I put in a support request and Ryan responded last night. It turned out it was because we're behind a proxy/firewall. He gave me a fix to get around that issue - some code to go into admin.php. I put that code in and saved admin.php, but now I can't even get into our admin anymore!
      (Just to clarify, I took the code back out and saved admin.php but that made no difference. It's definitely not the new code causing the error.)
      The errors relate to a lack of permission on the ProDrafts module (see attached screenshot). We do have a key, but evidently the code Ryan gave me to add the key in via admin.php isn't taking effect before the error is thrown...?
      I tried removing the ProDrafts directory from the modules directory, but that hasn't helped.
      Is there a hook I can put in somewhere to tell it not to load ProDrafts at all, or not check the permissions? Or is there some way to manually uninstall it from the file system?
      Thanks!
      Margaret

    • By FrancisChung
      Hi PW Community,
      I have a problem where a page is loading up fine on my local dev machine + 1 of the test sites, but not on another test site.

      They have identical PW (2.8.35?) and codebase installed.
      The 2 sites are hosted on the same hosting provider, as well as our other sites.
      1) Error Logs. There is nothing particularly strange logged on the PW Error log for all the sites. I am getting a "You must assign a template to the page before setting custom field values (title__data) [pageClass=Page, template=] (WireLog)" error, but I'm getting this error on working pages as well.
       However, there are some errors in our Hosting Provider's log. The error seems to point at some sort of permissioning issue regarding reading the image files?
      1.a) File / Dir permissions of Images  - I've checked file permissions on the normal and problematic sites. They are all identical
      2) .htaccess  -  I've tried running the .htaccess file from the working site on the problematic site - No Luck
      3)  codebase - I've done 3 comparisons. They are identical on all sites.
      4) wire directory - See above
      5) Behaviour - So the problematic site loads up most of its page as expected without problems. It's just a couple that it has issues with.
       
      Problematic URL Example  : http://kinder-reime.com/kindergedichte/kategorien/gedichte-fuer-kindergarten-und-schule/
      Working URL : http://finger-spiele.com/kindergedichte/kategorien/gedichte-fuer-kindergarten-und-schule/
      I've also attached the KIS Error Logs.
      Has anyone come across  behaviour like this before and what would be the way forward to fix this?
      KIS.Error.Logs
×
×
  • Create New...