Jump to content

404 error on changing page status


digitex
 Share

Recommended Posts

Hi Ryan and the processwire crew.

I had an interesting error come up today. I did up some new pages for a client, saved but left unpublished and later, tried to set the page status to published but hidden so the client could see it before it went live. When I hit the save button it returned a 404 page not found error. I tried several more times, logging out and then back in and even deleted the page and created a new one. It kept returning 404. I finally had to use PHPmyAdmin to make the changes manually.

Has that error been documented? I'm trying to determine if it's a database problem on my end or some obscure bug that just popped up today. I have to admit this is the first time I've done up a page and left it unpublished.

Using pw2.1

Link to comment
Share on other sites

Hi digitex, I am on v 2.2.0.1 and I just tried to emulate what you did, I created four pages, two I created and didn't even click publish (just left them as titles) and two I created, added content, saved, edited to untick-published. Then I left them a few minutes to make tea, then I returned and published all four. No problem.

I have no idea if it's more likely to be your version not being as late as mine or something and I am sure Ryan/others more knowledgeable will comment more.

  • Like 1
Link to comment
Share on other sites

Thanks for the reply Alan and for going to the trouble to try to replicate the problem. I created 3 pages and only one gave me the 404 error, the other two, handled in the same way, were no problem. If I knew it was just a weird glitch that might not ever happen again I would be cool with it but if it's perhaps a database issue that might lead to a corruption in the db then I'd start sweating a little.

I have downloaded the latest version and was planning to upgrade and since I don't really need to save and leave unpublished I just won't do that. Here's hoping I never see that again. :)

Link to comment
Share on other sites

Good luck with the latest version, if you still get the problem then post to let me know and I'll try it here again, but with more pages. And happy Easter fellow Ontarian :)

Link to comment
Share on other sites

Digitex, I've not seen/heard of this issue before, so thinking it may be isolated. I agree it would be good to go ahead and upgrade just in case the version had some side effect. If you can still reproduce the issue after that, let me know what PHP and MySQL version you are running so I can try to setup a similar test environment.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By gswoodman
      Hello all,
      I have recently installed ProcessWire as I am learning to develop my own personal website.
      The installation process was completed, pressed 'Login to Admin' and I am receiving a 404 error.
      I am using a GoDaddy Shared Hosting Package with Plesk installed.
      Does anyone have any experience with using ProcessWire on a shared hoasting package?
      Many Thanks.
    • By rolspace.net
      Hi Everyone
      I have a problem here. I have built a site with Processwire on localhost and then transferred to my customer's server. a) it's a windows server (unfortunately) and b) there is a domain-mapping for this site, the domain points to a folder of another domain. Sorry, I can't explain it any better, I don't really understand the different types of servers (why do they have to be different anyway...).
      My problem is, that I see the main website but not the admin page. Do I have to add anything to my .htaccess file?
      I also tried to include web.config file. Not .htaccess nor web.config file have an impact when changing its content. I really have no clue what to do!!
      Links: mcconnellacademy.ch, mcconnellacademy.ch/admin
      Thanks for any pointing in the right direction!
    • By Speed
      Hi Everyone, New here but not new to CMS and Template developing  . Early today, I've installed PW, it was successful, the result was flawless. But then, I realized I've encounter 404 error and was unable to go into admin. I've spend 4 hours going through troubleshooting guide following this link  http://processwire.com/docs/tutorials/troubleshooting-guide/page3  and I am not getting any luck, so I was hoping I could get some help from you so I can get started with PW
      First, the PW is running on localhost using MAMP 3.3.2 (free version).  The PW files is located inside MAMP/htdocs as subfolder called pwNew. So obvious inside htaccess the  Rewrite Base command should be 
      RewriteBase /pwNew (of course hashtags has been removed) if I did it right, then it didn't work for me!  So next, I went inside  /apache/conf/httpd.conf and  then changed... 'none' to 'All' 
       
      <Directory />     Options FollowSymLinks ExecCGI     AllowOverride All     Order deny,allow     Allow from all </Directory> Unfortunately, it didn't work for me.  I've confirmed twice... the mod_rewrite have been installed, up and running.
      Confirmation # 1 running mod_rewrite_test.php with this code below, 
      <?php if(in_array('mod_rewrite', apache_get_modules())) { echo 'mod_rewrite is installed.'; } else { echo 'mod_rewrite isn't installed.'; } ?> ...and then run it from browser

      Confirmation # 2 from phpinfo

      I really need your help and hope there are solution for it.
       
      Thanks in advance. 
    • By z0rk
      I've just installed the latest version of PW on debian 8 with apache2. The install went flawless; no errors. After the install completed I tried to access /processwire/ and failed with a 404 error. The home page of the site displays, but all links fail with 404 errors.
      Research suggests to edit .htaccess to make sure RewriteBase poinst to [path]/processwire/. I did that, but access to /processwire/ is still failing. I've also tried to enable AllowOverride All in the apache2 configuration file, but to no avail.
      Any suggestions?
      Thanks
    • By naruttam
      The Processwire version is ProcessWire 2.4.0 © 2015
      When attempting to save edits to the page, instead of getting the pw success message, I get the 404 page not found page.  
      This page in question cannot be deleted, moved, edited...nada.
      Page edit takes me to: http://www.mydomain....e/edit/?id=5772
      When I attempt to save the edits the address bar still says:
      http://www.mydomain....e/edit/?id=5772 but it displays the 404 Page Not Found page and changes are not saved.

      Also disabled Modsecurity on the server. Any ideas please
×
×
  • Create New...