Jump to content

New installation: site links 404 errors and /processwire/ access failure


z0rk
 Share

Recommended Posts

I've just installed the latest version of PW on debian 8 with apache2. The install went flawless; no errors. After the install completed I tried to access /processwire/ and failed with a 404 error. The home page of the site displays, but all links fail with 404 errors.

Research suggests to edit .htaccess to make sure RewriteBase poinst to [path]/processwire/. I did that, but access to /processwire/ is still failing. I've also tried to enable AllowOverride All in the apache2 configuration file, but to no avail.

Any suggestions?

Thanks

Link to comment
Share on other sites

I don't know your (Debian) GNU/Linux level relative to LAMP, so I will ask some questions...

Have you also enabled mod_rewrite (it is not by default)?

Have you restarted Apache2?

(Do you have /index.php/ in the url paths of the other pages?)

Are you using Debian's default LAMP "package"?

Can you give more details?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By gswoodman
      Hello all,
      I have recently installed ProcessWire as I am learning to develop my own personal website.
      The installation process was completed, pressed 'Login to Admin' and I am receiving a 404 error.
      I am using a GoDaddy Shared Hosting Package with Plesk installed.
      Does anyone have any experience with using ProcessWire on a shared hoasting package?
      Many Thanks.
    • By rolspace.net
      Hi Everyone
      I have a problem here. I have built a site with Processwire on localhost and then transferred to my customer's server. a) it's a windows server (unfortunately) and b) there is a domain-mapping for this site, the domain points to a folder of another domain. Sorry, I can't explain it any better, I don't really understand the different types of servers (why do they have to be different anyway...).
      My problem is, that I see the main website but not the admin page. Do I have to add anything to my .htaccess file?
      I also tried to include web.config file. Not .htaccess nor web.config file have an impact when changing its content. I really have no clue what to do!!
      Links: mcconnellacademy.ch, mcconnellacademy.ch/admin
      Thanks for any pointing in the right direction!
    • By Speed
      Hi Everyone, New here but not new to CMS and Template developing  . Early today, I've installed PW, it was successful, the result was flawless. But then, I realized I've encounter 404 error and was unable to go into admin. I've spend 4 hours going through troubleshooting guide following this link  http://processwire.com/docs/tutorials/troubleshooting-guide/page3  and I am not getting any luck, so I was hoping I could get some help from you so I can get started with PW
      First, the PW is running on localhost using MAMP 3.3.2 (free version).  The PW files is located inside MAMP/htdocs as subfolder called pwNew. So obvious inside htaccess the  Rewrite Base command should be 
      RewriteBase /pwNew (of course hashtags has been removed) if I did it right, then it didn't work for me!  So next, I went inside  /apache/conf/httpd.conf and  then changed... 'none' to 'All' 
       
      <Directory />     Options FollowSymLinks ExecCGI     AllowOverride All     Order deny,allow     Allow from all </Directory> Unfortunately, it didn't work for me.  I've confirmed twice... the mod_rewrite have been installed, up and running.
      Confirmation # 1 running mod_rewrite_test.php with this code below, 
      <?php if(in_array('mod_rewrite', apache_get_modules())) { echo 'mod_rewrite is installed.'; } else { echo 'mod_rewrite isn't installed.'; } ?> ...and then run it from browser

      Confirmation # 2 from phpinfo

      I really need your help and hope there are solution for it.
       
      Thanks in advance. 
    • By naruttam
      The Processwire version is ProcessWire 2.4.0 © 2015
      When attempting to save edits to the page, instead of getting the pw success message, I get the 404 page not found page.  
      This page in question cannot be deleted, moved, edited...nada.
      Page edit takes me to: http://www.mydomain....e/edit/?id=5772
      When I attempt to save the edits the address bar still says:
      http://www.mydomain....e/edit/?id=5772 but it displays the 404 Page Not Found page and changes are not saved.

      Also disabled Modsecurity on the server. Any ideas please
    • By Chris Falkenstein
      hello, 
      after i attemped to install a module -- the modules manager -- i can no longer access the 'modules' section in the admin.
      here's exactly how i got to this point
      i installed a fresh copy of pw (v 2.5.3) with the blank slate option.  install was completed without issue. wonderful.  directly after install i headed over to modules.processwire.com and downloaded the zip file for soma's module manager.  next i navigated back to the admin and over to the modules section. i chose to upload the modules manager zip file.  i selected the zip file from my desktop then hit upload, waited a bit then i got redirected to the 404 error page. and now i can not get to any page within the moduels section of the amdin.  i get redirected to the 404 error page.  i'm not sure where to start troubleshooting.  i restalled pw and attempted to install the module 2 more times as outlined above.  i get the same results.   
      any assistance would be greatly appreciated. 
×
×
  • Create New...