Jump to content
icietla

"Add new" and roles: templates missing

Recommended Posts

Hello,

my problem: with the role created for my client, the "add new" button don't list all templates authorized for this role.

With the admin role all template are listed:

post-1990-0-27901500-1445586661_thumb.gi

With the client role city (ville) and program (programme) are missing :

post-1990-0-10208800-1445586925_thumb.gi

Have you any idea?

Thanks a lot! :)

Share this post


Link to post
Share on other sites

Template settings are correct?

You have to check

- the rights for parent templates, too.

- allowed child templates there

- add new button activated for shure

what PW version?

regards mr-fan

Share this post


Link to post
Share on other sites

Hello mr-fan,

- the rights for parent templates, too : all inherit the rights from the home template, rights enabled for the client (see, modify, create, add). And in the three pages, my client can add all templates types!

- allowed child templates there: no problem for child/parents allowed, it's ok for all roles using the three page but theses templates not appears with the add shortcut menu. But again, it's ok for the admin role.

- add new button activated for shure : yes, that's why for the admin role, it works fine. 

 
What is strange is that it seems a problem of rights only for the shortcut menu with the client role...
 
My version; 2.6.19

Share this post


Link to post
Share on other sites

Thanks for your help.

I understand that there are two different things: "shortcuts" and now the "add new bookmarks".

The problem is the same in the "Pages > add new" that in the shortcuts button

All available for the admin:

post-1990-0-73581400-1445600695_thumb.gi

Two missing for the client role:

post-1990-0-96714800-1445600702_thumb.gi

But taking a look closer, I see that the 2 missing templates for the client are those that can add a new item in multiple possibles parents, like a new city in any of already department created.

For the admin, PW send a page to choose the unique parent among the possibles ones:

post-1990-0-20154600-1445601001_thumb.gi

On the contrary, for the client, PW seems to don't allow this. But, we can add items with multiple possibles parent using the page three, so the right for these templates are well allowed for this role. 

Do you think it is possible to have the same behavior (use shortcuts) when the client want to quickly add an item in any page of a given template?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By VeiJari
      Hi, this is the first we are trying to make a page that has only one type of user that has access to every page. 
      The other users should only have a given access to specific pages, not to the whole template.
      My structure
      -Field -Organisation -Project -Report I want that the "measurer" role only has access to "project x" and it's children, but no view access to every project, organisation or field. I've tried to do this with https://modules.processwire.com/modules/page-edit-per-user/ but it still needs a view access to the whole tree to see the "project x" page. Or is there something I haven't figured out?
      Maybe I have to make it via the API: a select field in the "organisation" template where the admins could add the users and then I use hook to update the privileges?
      Have you done something like this and how did you accomplish it?
      Any help would be appreciated.
       
    • By snck
      Hey there,
      for a client website I need to implement a "reviewer" role. "Reviewers" should be able to review new (unpublished) articles to give feedback to editors, but not have the permission to change them. 
      I built a new "reviewer" role that only has page-view permissions for the respective templates, but this permission does not include viewing unpublished pages. How can I grant them access to the unpublished articles without giving them page-edit permission?
      Cheers,
      Flo
    • By Pip
      Hi everyone!
      I'm trying out the Login/Register module for my site. Noted that the module assigns the newly registered user to login-register role. 
      Once you modify the login-register role's permissions, particularly adding page-edit, the new member role will be set to guest. 
      Thing is I'd like to grant my new users the power to create their own pages. Any advice? 
      Thanks. 
    • By snck
      Hey,
      I want my editors to be able to use the page lister, especially the bookmarks. I added the page-lister permission to the editor role, but Page lister ("Find" menu item) does not show. Is there anything else I have to do? Links to bookmarks work for the editors, but I would be glad to show them the menu item as well.
      Maybe this has something to do with the long history of the site (started with ProcessWire 2.4 and upgraded to 3.0.148 over the years)?
      Thanks,
      Flo 
    • By snck
      Hello,
      for a project I have pages with different “content areas“ that can be edited only by specific user roles. In the past I setup a fieldset (tab) containing all the fields that should be available to only one specific group of users and set the fields' view and edit permissions (in the Access tab) accordingly. The result was as expected: Users assigned to the specific role could see the tab, click on it, edit content, users without the role could not see the tab. After updating this installation to 3.0.148 yesterday I wanted to setup another tab following the same principle, but I have no "Access" tab for the fieldset to limit access to the specific role. I even tried cloning an existing (and still working) fieldset. The existing fieldset has some template overrides (screenshot attached) that lead to the desired behaviour, but I am not able to reproduce these settings because there is not "Access" tab for my fieldset in template context either.
      Is this a bug in 3.0.148? Has the fieldset fieldtype changed? Am I missing anything here?
      I am glad to hear from you guys.
      Cheers,
      Flo

×
×
  • Create New...