Jump to content

Media Manager


kongondo

Recommended Posts

On 2/5/2020 at 8:30 PM, xportde said:

Do you mean Image maximum width / height? So I misunderstood the notes Maximum width / height of resized images (pixels),

Yes.

On 2/5/2020 at 8:30 PM, xportde said:

I thought, this settings are for resizing, not for uploading?

They are for both. If using resizing feature, the images will be constrained to those limits. If they fall short of the minimum, the images are discarded. If not using resizing, original images should meet the minimum and maximum constraints. 

On 2/5/2020 at 8:30 PM, xportde said:

Maybe you could write the notes accordingly (Max width / height for uploaded images)?

Good idea. I'll see how to better word this. I am coming up blank at the moment 😁

Link to comment
Share on other sites

Downloading Media From Media Manager Library

I was recently asked whether it was possible to download media already uploaded to Media Manager. Currently, there is no automated way to do this. However, using the ProcessWire API, one can achieve this. Below is a starter code showing how one can download image media from Media Manager. I'll consider adding this feature to Media Manager.

Please note that I have deliberately left Tracy debugging statements in the code. You will want to wrap this around a check if user is Superuser.

// get limited number of media manager images
$mmPages = $pages->find('template=media-manager-image, limit=10');
$tempName = 'media_manager_downloads';// temporary name for folder to place images in

// 1. MAKE DIRECTORY
// @note: could have used $files->tempDir('hello-world'); but not working for some reason
// create a new directory in ProcessWire's cache dir
$copyTo = $config->paths->cache . $tempName;
if($files->mkdir($copyTo)) {
    // directory created: /site/assets/cache/media_manager_downloads/

    // 2. COPY IMAGES
    // get and copy image assets
    foreach($mmPages as $p) {
        $images = $p->media_manager_image;
        foreach($images as $image) {
            //bd($image->filename,'image path')// to debug image path
            $copyFrom = $image->filename;
            $bool = $files->copy($copyFrom, $copyTo);
            //bd($bool,'copied?');// just to test if files were copied
        }
    }

    // 3. ZIP IMAGES
    // if files were copied, zip them
    if(!empty($files->find($copyTo))){
        // create zip of all files in directory $copyTo to file $zip
        $zip = $config->paths->cache . "media-manager-image-files.zip";
        $result = $files->zip($zip, $copyTo);

        echo "<h3>These files were added to the ZIP:</h3>";
        foreach($result['files'] as $file) {
            echo "<li>" . $sanitizer->entities($file) . "</li>";
        }

        if(count($result['errors'])) {
            echo "<h3>There were errors:</h3>";
            foreach($result['errors'] as $error) {
                echo "<li>" . $sanitizer->entities($error) . "</li>";
            }
        }

        // 4. SEND FILES TO BROWSER FOR DOWNLOADING
        // if files were added to zip file, send them
        if(!empty($result['files'])){
            bd($zip,'files were added');
            $files->send($zip);
        }
    }

    else {
        bd('NO FILES FOUND!');
    }


}

Hope this helps.

  • Like 2
Link to comment
Share on other sites

  • 3 weeks later...

I just installed the Media Manager on a clean PW installation and encountered a problem: Multiple image upload is not working.

I am unter the "upload" tab and drag some images into the field. Then click "start". The upload progress bar is growing for 1 second then suddenly it shrinks back to zero and the image upload list is cleared. No images were uploaded. What is wrong? 
The image size is lower than the max upload size setting in my PHP.ini so that cannot be the reason. The images are about 3 MB each with a resolution of 5184x3456px. That should not be a problem at all?

Second - whenever I alter something in the "settings" tab it is NOT saved. For example: Upload mode -> Single file uploads set to false.

Link to comment
Share on other sites

20 hours ago, Stefanowitsch said:

I just installed the Media Manager on a clean PW installation and encountered a problem:

Hi @Stefanowitsch,

Sorry for the issues you are currently experiencing.

20 hours ago, Stefanowitsch said:

whenever I alter something in the "settings" tab it is NOT saved. For example: Upload mode -> Single file uploads set to false.

This is a strange one. It might mean Media Manager was not installed correctly and the settings page is not found. It might be the cause of your other issue.

Via email (using the email in your receipt) or PM could you please:

  1. Send me a screenshot of the open tree at Admin > Media Manager.
  2. Confirm that these fields were created: media_manager_audio, media_manager_document, media_manager_image, media_manager_settings, media_manager_video.
  3. Confirm that these templates were created: media-manager, media-manager-audio, media-manager-document, media-manager-image, media-manager-settings, media-manager-video.
  4. The version of ProcessWire you are using.
  5. The PHP version your server is running.
  6. Any error messages, in the console and in TracyDebugger (hopefully, you have this installed)

Thanks.

Link to comment
Share on other sites

Hi @kongondo

We have a problem with uploading some mp3 files.

We can't upload a specific .mp3 file in the media manager because on the server it returns application/octet-stream as mime-type instead of audio/mpeg.

But when I check with finfo or mime_content_type on a localhost it returns audio/mpeg mimetype.

Even when I check the mime-type on the mac osx terminal (file --mime-type -b filename) it returns audio/mpeg.

What should I do? I also can't find an online tool where the customer could repair the mp3 file or something.

I downloaded the file from the dropbox account/link of the customer.

The funny thing is, when i convert that mp3 file to wav it can be uploaded.

KR
Orkun

Link to comment
Share on other sites

@kongondo Any news on this? 

What I could do is, is to add the "application/octet-stream" mimetype for mp3 extensions. I could do this inside the method "mimeTypes" of the File "MediaManagerUtilities.php" but don't know if this is a good Idea.

KR
Orkun

Link to comment
Share on other sites

On 3/6/2020 at 7:48 AM, Orkun said:

@kongondo Any news on this? 

What I could do is, is to add the "application/octet-stream" mimetype for mp3 extensions. I could do this inside the method "mimeTypes" of the File "MediaManagerUtilities.php" but don't know if this is a good Idea.

KR
Orkun

Sorry for the late response @Orkun...

No, that wouldn't be a good idea. One, it would just get overwritten on an upload and secondly, that is not a correct mimetype for mp3s. 

On 3/9/2020 at 8:40 AM, Orkun said:

I found a tool which "fixed" the mp3 file so that I could upload it again in media manager.

Glad you got it sorted. 

It seems PHP will sometimes misclassify the the mimetypes of some mp3s. Here's a discussion about it on SO. This might also be of relevance (corrupt ID3 tags)

Link to comment
Share on other sites

Hi @kongondo

Is it normal that the folder in /site/assets/MediaManager/jqfu/.files_no_show/ is full of files/duplicate files? We can't upload any files anymore, because we are getting the error of duplicate media page (empty file upload result). It looks like he tries to create a page from a file from the .files_no_show folder but that page with the name already exists.

Isn't the /site/assets/MediaManager/jqfu/.files_no_show/ just a temporary folder? Shouldn't be the file deleted after the media page was created?

KR
Orkun

Link to comment
Share on other sites

Hi @Orkun,

On 3/20/2020 at 7:35 AM, Orkun said:

Isn't the /site/assets/MediaManager/jqfu/.files_no_show/ just a temporary folder?

Yes it is just a temporary folder.

On 3/20/2020 at 7:35 AM, Orkun said:

Shouldn't be the file deleted after the media page was created?

It should. It works fine here. Could you please tell me about your setup? (ProcessWire and PHP versions, etc).

I am not sure whether it is a file permission issue. Are you on a Windows machine?

Alternatively, maybe you are trying to upload very large images and the system does not finish and you are trying to re-upload?

Please let me know.

Link to comment
Share on other sites

Hello,

This is primarily directed to MAC users and/or MAMP users.

Recently, some Media Manager users have reported that their settings are not getting saved, especially the After Uploading setting. I have to replicate the issue on clean installs with nothing but MM, JqueryFileUpload and Tracy without success. Here's what we know so far:

  • The settings actually get saved in the Database; the issue is what is saved is not what gets displayed in the GUI. Meaning, it always shows the default setting.
  • For one user, the issue only appeared when they were using WAMP or XAMP. For the other user the issue appeared on both MAC and Windows. I don't have a MAC to test on.
  • I have tested on both single language and multilingual sites. I can't replicate the issue.
  • PHP, MySQL versions don't seem to be the issue. We've been testing on PHP 7.2+.
  • I have tested on both the latest master and dev versions of PW.
  • Those experiencing the issue see the same behaviour in Chrome, FF and Edge. I am not sure about Safari.
  • We don't think there's a browser extension interfering.
  • Media Manager version 012 (latest).

Is there anyone with MM version 012, a bit of time and preferably a MAC and MAMP who can help us figure this out please? Any other ideas?

Many thanks.

 

Link to comment
Share on other sites

Hi kongondo,

I just wanted to report a little UI inconsistency: I was editing a CKEditor-textarea and inserted a link by using "Select Media from Media Manager". In the Media Manager modal window, I used the table view, in order to see the filenames. Now, selecting any of the thumbnails didn't give any visual feedback. The red frame indicator only appears in the grid view, but not in the table view. I did a clean install of Processwire and Media Manager, but the issue persisted.

Update: I think I found the issue. Here is a fix for insertMediaLINK($s) in MediaManager.js:

Before:

$inputs.each(function () {
    // skip current input
    if ($(this).attr('id') == 'media-' + $dataValue) return;
    // invert checked status
    $(this).prop("checked", inverseState).change();
});

After:

$inputs.each(function () {
	// skip current input
	var $dv = $(this).attr('id').substr(6).replace('-tabular', '');
	if ($dv == $dataValue) return;
	// invert checked status
	$(this).prop("checked", inverseState).change();
});

The line was taken from removeMediaThumbsView($a) in InputfieldMediaManager.js.

Edited by nurkka
Found issue, (hopefully) fixed it
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
On 4/2/2020 at 3:14 PM, kongondo said:

Recently, some Media Manager users have reported that their settings are not getting saved, especially the After Uploading setting.

This seems to have been an issue with sites installed in sub-folders. I'll fix this in next update. 

Thanks.

Link to comment
Share on other sites

  • 4 weeks later...

Hi @kongondo,

On 2/27/2020 at 2:43 PM, Stefanowitsch said:

I just installed the Media Manager on a clean PW installation and encountered a problem: Multiple image upload is not working.

I am unter the "upload" tab and drag some images into the field. Then click "start". The upload progress bar is growing for 1 second then suddenly it shrinks back to zero and the image upload list is cleared. No images were uploaded. What is wrong?

I'm encountering the same problem as @Stefanowitsch on the latest Media Manager: Multiple image uploads not working, exactly how he described it. Did you find a solution?

Quote

Second - whenever I alter something in the "settings" tab it is NOT saved. For example: Upload mode -> Single file uploads set to false.

I do *not* experience this problem, so it may be unrelated...

Thank you 🙂

Link to comment
Share on other sites

Hi @dynweb,

Sorry about the issue you are encountering.

46 minutes ago, dynweb said:

Did you find a solution?

Yes. The value of PHP (php.ini) post_max_size was low. Please let me know what your settings are for the following:

  • post_max_size
  • memory_limit
  • file_uploads
  • upload_max_filesize
49 minutes ago, dynweb said:

I do *not* experience this problem, so it may be unrelated...

This one (settings not getting saved) was related (at least in one case) to ProcessWire being installed in a sub-directory 🙂

 

Link to comment
Share on other sites

  • 3 weeks later...

Hi @Mustafa-Online,

1 hour ago, Mustafa-Online said:

I have just bought the Media Manager Module,

Thanks for the purchase.

1 hour ago, Mustafa-Online said:

Upload is not working!
when i click on start button nothing shows on media manager page!

Sorry about this. 

Please check and confirm the following:

  • post_max_size
  • memory_limit
  • file_uploads
  • upload_max_filesize

In addition, please confirm the following:

  • What are you trying to upload?
  • Are they perhaps smaller/larger than what you have in the settings for minimum/maximum sizes?
  • Is this a multilingual site?
  • ProcessWire version.
  • PHP version.

Thanks.

Link to comment
Share on other sites

@kongondo

  • post_max_size = 512M
  • memory_limit = 512M
  • file_uploads = On
  • upload_max_filesize = 2G

--------------------------------------------

  • What are you trying to upload: I tried almost every type (jpeg png pdf doc docx ppt mp3 mp4)
  • Are they perhaps smaller/larger than what you have in the settings? I even tried 3kb file size with no luck
  • Is this a multilingual site? No It's a fresh installtion
  • ProcessWire version: PW Dev 3.0.156
  • PHP version: 7.2.27
Link to comment
Share on other sites

@Mustafa-Online,

What are you Media Manager settings for the following?

After Uploading

mm_settings_after_uploading.thumb.png.68f13205c4f27fbb9a7f85df5da2ba4a.png

 

Image Extensions

mm_settings_image_extensions.thumb.png.a568c884885b54df4584dacdd6511139.png

Have a look at the dev tools, network tab, xhr when uploading:

  • Are the files posted?
  • What response does the server return?

Do you have the following directories under /site/ ?

  • /sites/assets/MediaManager/jqfu
  • /sites/assets/MediaManager/uploads

Btw, post_max_size needs to be bigger than upload_max_filesize. See this post by Horst.

 

Could you try with config->debug=true and TracyDebugger and let me know if you get any errors please? I have just tested with the latest dev version and it works OK.

Link to comment
Share on other sites

@kongondo -- Yes I have  jqfu & uploads folders. I also modeified the post_max_size so it's bigger than upload_max_filesize

I get this in network tab >> Notice: Media Manager: No valid media found to add to Media Library

trc.thumb.PNG.9795df1c6467514111bffb52d9e73ee4.PNG
 



mdddd.PNG.c61f265e9aa42d02b089273cfb5f3f80.PNG

media-1.PNG.3168054007b428906ec641b783241c7e.PNG
 

One More thing: I checked again, all the files I tried to upload are available in PW assets folder!
 

Link to comment
Share on other sites

2 hours ago, Mustafa-Online said:

One More thing: I checked again, all the files I tried to upload are available in PW assets folder!

Please confirm where exactly in the assets folder. With the settings you've shown me, they should be in /site/assets/MediaManager/jqfu/.files_no_show

Please also confirm:

  • Are you on MAMP?
  • Are you on a Windows or a Mac or other?
  • Is ProcessWire installed in a sub-folder?

Sorry for the hassle. I'd really like to get to the bottom of why for most MM works flawlessly and for a few others there are upload issues. 

Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By MarkE
      This fieldtype and inputfield bundle was built for storing measurement values within a field, rendering them in a variety of formats and converting them to other units or otherwise modifying them via the API.
      The API consists of a number of predefined functions, some of which include...
      render() for rendering the measurement object, valueAs() for converting the value to another unit value, convertTo() for converting the whole measurement object to different units, and add() and subtract() for for modifying the stored value by the value (converted as required) in another measurement. In the admin the inputfield includes a checkbox (which can be optionally disabled) for converting values on page save. For an example if a value was typed in as centimeters, the unit was changed to metres, and the page saved with this checkbox selected, said value would be automatically converted so that e.g. 170 cm becomes 1.7 m.

      A simple length field using Fieldtype Measurement and Inputfield Measurement.
      Combination units (e.g. feet and inches) are also supported.
      Please note that this module is 'proof of concept' at the moment - there are limited units available and quite a lot of code tidying to do. More units will be added shortly.
      See the GitHub at https://github.com/MetaTunes/FieldtypeMeasurement for full details and updates.
    • By tcnet
      File Manager for ProcessWire is a module to manager files and folders from the CMS backend. It supports creating, deleting, renaming, packing, unpacking, uploading, downloading and editing of files and folders. The integrated code editor ACE supports highlighting of all common programming languages.
      https://github.com/techcnet/ProcessFileManager

      Warning
      This module is probably the most powerful module. You might destroy your processwire installation if you don't exactly know what you doing. Be careful and use it at your own risk!
      ACE code editor
      This module uses ACE code editor available from: https://github.com/ajaxorg/ace

      Dragscroll
      This module uses the JavaScript dragscroll available from: http://github.com/asvd/dragscroll. Dragscroll adds the ability to drag the table horizontally with the mouse pointer.
      PHP File Manager
      This module uses a modified version of PHP File Manager available from: https://github.com/alexantr/filemanager
       
    • By tcnet
      This module implements the website live chat service from tawk.to. Actually the module doesn't have to do much. It just need to inserted a few lines of JavaScript just before the closing body tag </body> on each side. However, the module offers additional options to display the widget only on certain pages.
      Create an account
      Visit https://www.tawk.to and create an account. It's free! At some point you will reach a page where you can copy the required JavaScript-code.

      Open the module settings and paste the JavaScript-code into the field as shown below. Click "Submit" and that's all.

      Open the module settings
      The settings for this module are located int the menu Modules=>Configure=>LiveChatTawkTo.

       
    • By tcnet
      Session Viewer is a module for ProcessWire to list session files and display session data. This module is helpful to display the session data of a specific session or to kick out a logged in user by simply delete his session file. After installation the module is available in the Setup menu.

      The following conditions must be met for the module to work properly:
      Session files
      Session data must be stored in session files, which is the default way in ProcessWire. Sessions stored in the database are not supported by this module. The path to the directory where the session files are stored must be declared in the ProcessWire configuration which is by default: site/assets/sessions.
      Serialize handler
      In order to transform session data easier back to a PHP array, the session data is stored serialized. PHP offers a way to declare a custom serialize handler. This module supports only the default serialize handlers: php, php_binary and php_serialize. WDDX was dropped in PHP 7.4.0 and is therefore not supported by this module as well as any other custom serialize handler. Which serialize handler is actually used you can find out in the module configuration which is available under Modules=>Configure=>SessionViewer.

      Session data
      The session data can be displayed in two different ways. PHP's default output for arrays print_r() or by default for this module nice_r() offered on github: https://github.com/uuf6429/nice_r. There is a setting in the module configuration if someone prefers print_r(). Apart from the better handling and overview of the folded session data the output of nice_r() looks indeed nicer.

      Links
      ProcessWire module directory
      github.com
    • By Robin S
      Repeater Easy Sort
      Adds a compact "easy-sort" mode to Repeater and Repeater Matrix, making those fields easier to sort when there are a large number of items.
      The module also enhances Repeater Matrix by allowing a colour to be set for each matrix type. This colour is used in the item headers and in the "add new" links, to help visually distinguish different matrix types in the inputfield.
      Screencasts
      A Repeater field

      A Repeater Matrix field with custom header colours

      Easy-sort mode
      Each Repeater/Matrix item gets an double-arrow icon in the item header. Click this icon to enter easy-sort mode.
      While in easy-sort mode:
      The items will reduce in width so that more items can be shown on the screen at once. The minimum width is configurable in the field settings. Any items that were in an open state are collapsed, but when you exit easy-sort mode the previously open items will be reopened. You can drag an item left/right/up/down to sort it within the items. The item that you clicked the icon for is shown with a black background. This makes it easier to find the item you want to move in easy-sort mode. You can click an item header to open the item. An "Exit easy-sort mode" button appears at the bottom of the inputfield. Configuration
      In the field settings for Repeater and Repeater Matrix fields you can define a minimum width in pixels for items in easy-sort mode. While in easy-sort mode the items will be sized to neatly fill the available width on any screen size but will never be narrower than the width you set here.
      In the field settings for Repeater Matrix you can define a custom header colour for each matrix type using an HTML "color" type input. The default colour for this type of input is black, so when black is selected in the input it means that no custom colour will be applied to the header.
      Exclusions
      The easy-sort mode is only possible on Repeater/Matrix fields that do not use the "item depth" option.
       
      https://github.com/Toutouwai/RepeaterEasySort
      https://processwire.com/modules/repeater-easy-sort/
×
×
  • Create New...