Jump to content

After install error 404 except for homepage


Recommended Posts


I am new to PW and can't figure out how to get it to work. I'm working on a project and decided to use something different than Wordpress for once.

The install went perfectly fine, not a single error, but after that I got stuck at the basic home page. Navigating to the subpages of the Admin Panel leaves me at the 404 page. Now I did find other topics containing the same problem or something like it, but none of the suggested solutions worked for me. 

I am running Xampp 5.6.12-0 on OS X El Capitan (for what it's worth). In the htdocs folder I have a folder for the website which contains the Processwire files.

So heres the current state:

  • mode_rewrite is active/working.
  • In http.conf I've set all the AllowOverride to 
    AllowOverride All
     just so that I didn't pick the wrong one.
  • My .htaccess file it recognized (I did the 'aklvjsdvdislaj' test ;] )
  • I read somewhere that it was better to comment these three, so I did: 
    #Options -Indexes
    #Options +FollowSymLinks
    #Options +SymLinksifOwnerMatch
  • I tried commenting/uncommenting these:

  # RewriteBase /
  # RewriteBase /my%20website/
  # RewriteBase /~user/
  1. Uncommenting the first one gets me redirected to the Xampp dashboard.

  2. The second one does nothing for me in this state except showing the same 404 page but if I change it, like adding /processwire/, I get Internal Server Error 500.

  3. And if I uncomment the third one I don't get the PW 404 page but the basic 404 page.

So at this point I'm getting a little tired of putting so much effort into simply getting an CMS to work. But I do think Processwire is perfect for my current project.

Thank you in advance,


Link to comment
Share on other sites

I had to uncomment the middle rewrite_base shown in .htaccess using xampp on windows 10.  Yours appears to have an emedded space in the alias/directory name, maybe that's causing the rewrite to fail for you?  Just guessing, but I'd try renaming the site alias without any space, and editing your .htaccess accordingly.

  • Like 1
Link to comment
Share on other sites

but I'd try renaming the site alias without any space, and editing your .htaccess accordingly.

Oh wow this did the trick for me! The folder I have the website stored in is named after the owners company, which exists of multiple words. So I figured replacing the spaces with %20 in .htaccess would be enough but I guess not.

Thank you very much!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...