Jump to content
kongondo

Module: RuntimeMarkup Fieldtype & Inputfield

Recommended Posts

Hi @pwfans,

Welcome to the forums. I'm glad you are finding the module useful. 

On 7/13/2018 at 4:01 AM, pwfans said:

Button is actually <a href> to template which will open new page (yes very ugly behaviour, read below) contain custom php code , not inside <form> action because <form> not allowed inside textarea.

To prevent opening new page when click the button, make an <iframe> inside the template as a target button, that's it, beautifully execution like native form in admin page.

Could you please provide more information regarding this approach? I'm sure it would come handy to others using to look this module. For instance, what template are you referring to? A template file? Also, the bit about the <form> and the textarea is not clear.

Thanks!

Share this post


Link to post
Share on other sites
11 hours ago, kongondo said:

Hi @pwfans,

Welcome to the forums. I'm glad you are finding the module useful. 

Could you please provide more information regarding this approach? I'm sure it would come handy to others using to look this module. For instance, what template are you referring to? A template file? Also, the bit about the <form> and the textarea is not clear.

Thanks!

Sure, first pardon for my english 😞

1. Create  "wireRenderFile('name-of-file')" contain html code <a href='link to page x' target='iframe x'> link AND small size <iframe name="x"> depend on how much text result will be, give css class to a href so it is like any other in admin page button, iframe used here so when a href above clicked, the result will be displayed in iframe, not opening in new page.
DO NOT use <form><button></button></form> in this page, it can't be executed.

2. Create new 'page x'  and 'template x' file as a href link target in step 1 , processing code will be inside this template file, you can really flexible here by using get URL parameter in step 1, such ?id=something&status=something, example case is in invoice page, you can send different content email notification (unpaid vs paid) using one button.

Hope this can help somebody else trying to send mail in admin page edit.

  • Like 2

Share this post


Link to post
Share on other sites
33 minutes ago, pwfans said:

Hope this can help somebody else trying to send mail in admin page edit.

Thanks for the explanation! 🙂

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, pwfans said:

Hope this can help somebody else trying to send mail in admin page edit.

Thank you for posting this. Sounds like an approach I could have taken. I chose to solve this a slightly different way though.

  • Like 1

Share this post


Link to post
Share on other sites

On the module FieldtypeRuntimeMarkup I have error according to roles. As superuser I don't have any error but as contributor I have
trying to Get property on non-object and the html code in the field is displayed as source.

The line pointed at is this one

 protected function renderMarkup(Page $page, Field $field) {

                //if code field is empty return early
                if(!$field->runtimeFields) return;

                //locally scope $pages to eval()
                $pages = $this->wire('pages');

    ------>    $str = eval($field->runtimeFields);

                //since we are dealing with custom PHP code but also want to make sure that only markup is returned
                //if eval() returns anything other than a string or an integer, we throw an error (e.g. if an object or array is returned)
                if (is_string($str) || is_int($str)) return $str;
                //we need to check if we are in admin. Otherwise with an error, in the frontend the name of the the Fieldtype is returned if we echo out the field
                elseif($this->wire('process')->className() == 'ProcessPageEdit') return $this->error($this->_('Only strings and integers should be returned by your custom code! $

        }

Thank you

Share this post


Link to post
Share on other sites

The error is caused by the code you entered in the field settings. The eval line above just executes the configured code. So if you show us that code, it might be possible to pinpoint the exact issue.

  • Like 2

Share this post


Link to post
Share on other sites

Hi BitPoet,

Here is my code
 

$texte="";
$leslangues=array(1=>"fr", 2=>"de",3=>"en",4=>"es",5=>"he",6=>"it",7=>"pt",8=>"ru");
foreach ($leslangues as $langue => $langue_str){
$element = $pages->find("template=clef, langue=$langue, limit=1, sort=-id")->first()->title;
$nombre=(int) filter_var($element, FILTER_SANITIZE_NUMBER_INT);
if (!$nombre){
$nombre=1;
}
$texte.="<b>$langue_str</b> : $nombre, ";
unset($nombre);
}
$texte=rtrim(rtrim($texte),",");
return $texte;

Thank you for your help.

Share this post


Link to post
Share on other sites

Since the only line with property access is

$element = $pages->find("template=clef, langue=$langue, limit=1, sort=-id")->first()->title;

it seems that your selector returns no results, so the call to first() returns null and accessing the title leads to the error. Your contributor account may not have permissions on the template or the pages in question may be hidden or unpublished. Depending on the exact scenario, an additional selector is probably necessary (see the link for details).

  • Like 1

Share this post


Link to post
Share on other sites

What I don't understand is that the field is displayed anyway with the right data (each language has a number) but displaying the b tag.

Share this post


Link to post
Share on other sites

Thank you very Much BitPoet for your help, I was able to solve adding check_access=0 in my selector.

Great!

Share this post


Link to post
Share on other sites

Looking for help on this one. I have a RuntimeMarkup field in a template.

When I only return a string with no HTML markup, all is well. See image 1 where the RTM field is "Skills" and it's returning the title of an auto-generated FormBuilder entry with no HTML.

642448032_Screenshot2019-01-1618_09_33.thumb.png.2c41d0e50e8408dd4e92a2492fbb52d5.png

When I try to output more info from the FormBuilder entry & format it, the page CSS loses the plot. Not only are the UiKit3 styles ignored, much of the page CSS is broken too - note the Save Edit button and the stacked-rather-than-styled fields above it.

1230224745_Screenshot2019-01-1618_11_11.thumb.png.49a18a5986e9b397eb8c95169684841c.png

RTM CSS file is as default and all that's returned to the field is a valid string. I've even tried returning a valid HTML string with heading & paragraph tags to take FormBuilder out of the equation.

The output string is:

    <div>
      <h3 class="uk-h3">Skills</h3>
      <div class="uk-width-3-4">some other skill</div>
      <div class="uk-width-1-4">65%</div>
      <div class="uk-width-3-4">talking under water</div>
      <div class="uk-width-1-4">80%</div>
      <div class="uk-width-3-4">Yawning</div>
      <div class="uk-width-1-4">100%</div>
      <div class="uk-width-3-4">Balloon animals</div><div class="uk-width-1-4">80%</div>
</div>

Actually doesn't seem to matter what HTML tags or classes I enter, as soon as I do, the page CSS breaks. Believe me, I tried lots!

RuntimeMarkup is a @kongondo module

Any suggestions on where and how to fix?

PS: Text in the summary field comes from https://baconipsum.com/ - I like it spicy!

Share this post


Link to post
Share on other sites

@Chris Bennett ummn, not sure... went to PW Modules to get it - version 0.0.2

According to the Modules site & @kongondo's github site, I am.

There are a couple of modules that do similar. Please give me the URL to the one you used 😊

It's important to this site that I can "do stuff" in PHP/PW before outputting the string

Thanks

Share this post


Link to post
Share on other sites
1 minute ago, psy said:

@Chris Bennett ummn, not sure... went to PW Modules to get it - version 0.0.2

According to the Modules site & @kongondo's github site, I am.

There are a couple of modules that do similar. Please give me the URL to the one you used 😊

It's important to this site that I can "do stuff" in PHP/PW before outputting the string

Thanks

No worries Psy, give me a minute to look-see what I have and try to track down where I got it 

Share this post


Link to post
Share on other sites

@Chris Bennett thanks, a step in the right direction. Now can output direct HTML and it works fine but still problems when I try to construct the string from my function

Share this post


Link to post
Share on other sites

@psy,

I have moved your topic here since this is the support forum of the module 🙂

Apologies, I have not had the time to finish up on some new features and merger the dev version into master. 

11 minutes ago, psy said:

still problems when I try to construct the string from my function

I don't understand this. Please clarify:

  1. What function is this? Can we see the code please
  2. Where are you calling the function? Directly in RuntimeMarkup field settings or it is in a file and you are calling it using wireRenderFile() or $files?
  3. Errors in dev console?
  4. Can we see the output from the FormBuilder entry

Share this post


Link to post
Share on other sites

@kongondo thanks for chipping in 🙂 

My function is in a custom module and the code in the RTM field is:

$custom = $this->wire('modules')->get('CustomFunctionsTBR');
return $custom->getJobSeekerData ($page);

The function in CustomFunctionsTBR is:

    function getJobSeekerData ($page) {

        $skills = $this->formMultiple('jobseeker_skills', $page->user_id);
        $out = "";
        $out .= "<h3 class='uk-h3'>Skills</h3>";
        foreach ($skills['entries'] as $entry){
            $out .= "<div class='uk-width-3-4'>" . $entry['skill_name'] . "</div><div class='uk-width-1-4'>" . $entry['skill_level']. "%</div>";
        }
        return $out;
    }

Where $this->formMultiple function queries the FormBuilder entries for records based on a user id saved (but not displayed) on the page.

There are no errors in the dev console.

Output from var_dump just prior to returning $out in the CustomFunctionsTBR FormBuilder entry:

string(355) "<h3 class='uk-h3'>Skills</h3><div class='uk-width-3-4'>some other skill</div><div class='uk-width-1-4'>65%</div><div class='uk-width-3-4'>talking under water</div><div class='uk-width-1-4'>80%</div><div class='uk-width-3-4'>Yawning</div><div class='uk-width-1-4'>100%</div><div class='uk-width-3-4'>Balloon animals</div><div class='uk-width-1-4'>80%</div>"
string(355) "<h3 class='uk-h3'>Skills</h3><div class='uk-width-3-4'>some other skill</div><div class='uk-width-1-4'>65%</div><div class='uk-width-3-4'>talking under water</div><div class='uk-width-1-4'>80%</div><div class='uk-width-3-4'>Yawning</div><div class='uk-width-1-4'>100%</div><div class='uk-width-3-4'>Balloon animals</div><div class='uk-width-1-4'>80%</div>"

Seems to be rendering the output twice - have heard of this anomaly happening before, eg in certain repeater matrix situations...???

Or maybe it's late and I'm tired.

Any/all suggestions to fix are welcome.

Share this post


Link to post
Share on other sites

@psy,

Thanks for the info.

I have not been able to replicate this. I've used your example HTML strings and it works just fine. Page Edit renders fine. I even tried with invalid/broken HTML and nothing breaks; it works OK. 

3 hours ago, psy said:

When I try to output more info from the FormBuilder entry & format it,

I missed this earlier. What do you mean 'format it'?

I'm wondering if your string is maybe returning invalid HTML that somewhere trips the browser? Just guessing. Other than that, RuntimeMarkup's CSS and JS files are blank; they never return anything. I need to remove them actually as they don't do anything.

If all else fails, I'm happy to have a look around your install if that's possible.

  • Like 2

Share this post


Link to post
Share on other sites

@kongondo, thank you!

New day here and taking another look. I noticed in the code that even though I'm only calling FormBuilder to get the entries, all the FB scripts & css are loading into the <head>. Digging deeper to see if this is causing a conflict. Grateful for your offer to look around the code if I can't resolve it. Will keep you posted.

 

More: Yep, FormBuilder files seem to be the problem. Now to figure out how to use FB in admin area to get the entries without the scripts loading.

 

SOLVED: One of the things my custom function 'formsMultiple' did was render the form and add the output to the final returned array. Works great on the front end but not needed here. Made the form rendering optional in the 'formsMultiple' function and in the RTM code, said don't do it. End result is RTM field and rest of the admin page display as expected. Thanks for the help & pointing me in the right direction.

Edited by psy
Solved problem
  • Like 1

Share this post


Link to post
Share on other sites

I just had a very weird issue today... I'll try and describe it as best as I can:

I have a frontend search form (text search and filters), which used to work fine before I have installed and used the RTMU module. Today the following fatal error appeared:

Spoiler

Exception: Field 'offer_reference_chooser' is runtime and not queryable (in /home/sitecom/www/dev.webapp/site/assets/cache/FileCompiler/site/modules/FieldtypeRuntimeMarkup/FieldtypeRuntimeMarkup.module line 181)

#0 /home/sitecom/www/dev.webapp/wire/core/PageFinder.php(1268): FieldtypeRuntimeMarkup->getMatchQuery(Object(ProcessWire\DatabaseQuerySelect), 'field_offer_ref...', 'data', '%=', '')
#1 /home/sitecom/www/dev.webapp/wire/core/Wire.php(386): ProcessWire\PageFinder->___getQuery(Object(ProcessWire\Selectors), Array)
#2 /home/sitecom/www/dev.webapp/wire/core/WireHooks.php(723): ProcessWire\Wire->_callMethod('___getQuery', Array)

PW basically tripped over these lines:

public function getMatchQuery($query, $table, $subfield, $operator, $value) {
	// we don't allow this field to be queried
	throw new WireException("Field '{$query->field->name}' is runtime and not queryable");
}

Now, the strange thing is: I am carefully constructing my selector (only pages within parent 1041, with template 'project' etc.etc.). The only template that used the RTMU inputfield was NOT the template I was querying. I have used it in another template, along with a page-reference field. Now this page-reference field was configured to show template 'project' pages, and children of page 1041.

Now that I have deleted the inpufields / removed them from my other template, everything works fine again.

How can it happen that this inputfield is somehow interferring a PW selector / search?

For a second, I thought I could also just comment this line:

// throw new WireException("Field '{$query->field->name}' is runtime and not queryable");

but then again, I don't know what else I could possibly break somewhere else by accident.

@kongondo Do you have any idea? Did you ever run into similar issues?

SERVER DETAILS
ProcessWire: 3.0.124
PHP: 7.2.14
Webserver: Apache/2.4
MySQL: 10.1.35-MariaDB

InputfieldRuntimeMarkup: 0.0.2
TracyDebugger: 4.15.8
 

PS

The module worked fine for me otherwise! I have used it to add a link which opens a frontend-page in a modal:

return '<a class="pw-panel pw-panel-reload ui-corner-all ui-button ui-widget ui-corner-all ui-state-default" href="https://dev.webapp.mysite.com/somepage/" data-tab-text="Choose x y z" data-tab-icon="eye" id="proj_chooser" role="menuitem"><i class="fa fa-fw fa-search"></i> search / choose</a>';

 

Edited by dragan
added PS

Share this post


Link to post
Share on other sites
8 hours ago, dragan said:

Do you have any idea? Did you ever run into similar issues?

That's strange. I've never seen this.

I could do some testing but I'm finding it a bit hard to follow your setup (the project template, 1041, etc). If I could see an illustration of how everything connects plus your selector string as well as any code or setup you use for the page-reference field, that would help. Seeing what Tracy returns as a final selector would also be helpful.

Share this post


Link to post
Share on other sites

How do I get a reference to the repeater page, instead of the page the repeater is on?
$page->id returns the parent or containing page, rather than the repeater id.

[SOLVED]

$value = $this->hasPage->data['some_field'];

 

Share this post


Link to post
Share on other sites

Hey @kongondo - I am back working on that project that makes heavy use of this field and I just replaced the:

return $this->renderMarkup($page, $field);

with:

return true;

for the sleep, wakeup, and loadPageField methods and it is bringing calls to the render method back to just one, which is really important because it contains some heavy querying.

I am fine with this mod for my needs, but I wonder if you'd consider these as an option for when the module is only used in the admin. The render() method in the InputRuntimeMarkup file takes care of the actual rendering without all these duplicate calls to renderMarkup().

What do you think?

  • Like 3

Share this post


Link to post
Share on other sites
5 hours ago, adrian said:

I am fine with this mod for my needs, but I wonder if you'd consider these as an option for when the module is only used in the admin. The render() method in the InputRuntimeMarkup file takes care of the actual rendering without all these duplicate calls to renderMarkup().

What do you think?

Thanks for resolving the issue! I don't get the bit about only used in admin; do you mean use a condition to check whether in admin? If you tested and it works find in the frontend as well with your mod, that's great! If the mod affects the frontend, then we can do the condition check for admin. It's been a while since I looked at the module and the master branch is beginning to really lag behind the dev branch. If you can write some code for me here rather than a PR, I'll appreciate it, thanks.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gebeer
      I am happy to present my new fieldtype FieldtypeImageFromPage. It is made up of 2 modules:
      Fieldtype Image Reference From Another Page is a Fieldtype that stores a reference to a single image from another page. The image can be selected with the associated Inputfield.
      Inputfield Select Image From Page is an Inputfield to select a single image from images on a predefined page and it's children.
      And there also is a helper module that takes care of cleanup tasks.
      This module evolved out of a discussion about my other Module FieldtypeImagePicker.  It caters for use cases where a set of images is being reused multiple times across a site. With this fieldtype these images can be administered through a chosen page. All images uploaded to that page will be available in the inputfield.
      When to use ?
      Let editors choose an image from a set of images that is being used site-wide. Ideal for images that are being re-used across the site.
      Suited for images that are used on multiple pages throughout the site (e.g. icons).
      Other than the native ProcessWire images field, the images here are not stored per page. Only references to images on another page are stored. This has several advantages:
      one central place to organize images when images change, you only have to update them in one place. All references will be updated, too. (Provided the name of the image that has changed stays the same) Features
      Images can be manipulated like native ProcessWire images (resizing, cropping etc.) Image names are fully searchable through the API Accidental image deletion is prevented. When you want to delete an image from one of the pages that hold your site-wide images, the module searches all pages that use that image. If any page contains a reference to the image you are trying to delete, deletion will be prevented. You will get an error message to help you edit those pages and remove references there before you can finally delete the image. How to install and setup
      Download and install this module like any other modules in ProcessWire Create a page in the page tree that will hold your images. This page's template must have an images field Upload some images to the page you created in step 2 Create a new field. As type choose 'Image Reference From Another Page'. Save the field. In 'Details' Tab of the field choose the page you created in step 2 Click Save button Choose the images field name for the field that holds your images (on page template from step 2) Click Save button again Choose whether you want to include child pages of page from step 2 to supply images Add the field to any template You are now ready to use the field View of the inputfield on the page edit screen:

      View of the field settings

      The module can be installed from this github repo. Some more info in the README there, too.
      In my tests it was fairly stable. After receiving your valued feedback, I will eventually add it to the modules directory.
      My ideas for further improvement:
      - add ajax loading of thumbnails
      Happy to hear your feedback!
       
    • By gebeer
      Although the PW backend is really intuitive, ever so often my clients need some assistance. Be it they are not so tech savvy or they are not working in the backend often.
      For those cases it is nice to make some help videos available to editors. This is what this module does.
      ProcessHelpVideos Module
      A Process module to display help videos for the ProcessWire CMS. It can be used to make help videos (screencasts) available to content editors.
      This module adds a 'Help Videos" section to the ProcessWire backend. The help videos are accessible through an automatically created page in the Admin page tree. You can add your help videos as pages in the page tree. The module adds a hidden page to the page tree that acts as parent page for the help video pages. All necessary fields and templates will be installed automatically. If there are already a CKEditor field and/or a file field for mp4 files installed in the system, the module will use those. Otherwise it will create the necessary fields. Also the necessary templates for the parent help videos page and it's children are created on module install. The module installs a permission process-helpvideos. Every user role that should have access to the help video section, needs this permission. I use the help video approach on quite a few production sites. It is stable so far and well received by site owners/editors. Up until now I installed required fields, templates and pages manually and then added the module. Now I added all this logic to the install method of the module and it should be ready to share.
      The module and further description on how to use it is available on github: https://github.com/gebeer/ProcessHelpVideos
      If you like to give it a try, I am happy to receive your comments/suggestions here.
    • By Robin S
      A module created in response to the topic here:
      Page List Select Multiple Quickly
      Modifies PageListSelectMultiple to allow you to select multiple pages without the tree closing every time you select a page.
      The screencast says it all:

       
      https://github.com/Toutouwai/PageListSelectMultipleQuickly
      https://modules.processwire.com/modules/page-list-select-multiple-quickly/
    • By gebeer
      Hello all,
      sharing my new module FieldtypeImagePicker. It provides a configurable input field for choosing any type of image from a predefined folder.
      The need for it came up because a client had a custom SVG icon set and I wanted the editors to be able to choose an icon in the page editor.
      It can also be used to offer a choice of images that are used site-wide without having to upload them to individual pages.
      There are no image manipulation methods like with the native PW image field.
      Module and full description can be found on github https://github.com/gebeer/FieldtypeImagePicker
      Kudos to @Martijn Geerts. I used his module FieldTypeSelectFile as a base to build upon.
      Here's how the input field looks like in the page editor:

      Hope it can be of use to someone.
      If you like to give it a try, I'm happy to hear your comments or suggestions for improvement. Eventually this will go in the module directory soon, too.
    • By bernhard
      @Sergio asked about the pdf creation process in the showcase thread about my 360° feedback/survey tool and so I went ahead and set my little pdf helper module to public.
      Description from PW Weekly:
       
      Modules Directory: https://modules.processwire.com/modules/rock-pdf/
      Download & Docs: https://github.com/BernhardBaumrock/RockPDF
       
      You can combine it easily with RockReplacer: 
      See also a little showcase of the RockPdf module in this thread:
       
×
×
  • Create New...