kongondo

Module: RuntimeMarkup Fieldtype & Inputfield

Recommended Posts

Hi @pwfans,

Welcome to the forums. I'm glad you are finding the module useful. 

On 7/13/2018 at 4:01 AM, pwfans said:

Button is actually <a href> to template which will open new page (yes very ugly behaviour, read below) contain custom php code , not inside <form> action because <form> not allowed inside textarea.

To prevent opening new page when click the button, make an <iframe> inside the template as a target button, that's it, beautifully execution like native form in admin page.

Could you please provide more information regarding this approach? I'm sure it would come handy to others using to look this module. For instance, what template are you referring to? A template file? Also, the bit about the <form> and the textarea is not clear.

Thanks!

Share this post


Link to post
Share on other sites
11 hours ago, kongondo said:

Hi @pwfans,

Welcome to the forums. I'm glad you are finding the module useful. 

Could you please provide more information regarding this approach? I'm sure it would come handy to others using to look this module. For instance, what template are you referring to? A template file? Also, the bit about the <form> and the textarea is not clear.

Thanks!

Sure, first pardon for my english 😞

1. Create  "wireRenderFile('name-of-file')" contain html code <a href='link to page x' target='iframe x'> link AND small size <iframe name="x"> depend on how much text result will be, give css class to a href so it is like any other in admin page button, iframe used here so when a href above clicked, the result will be displayed in iframe, not opening in new page.
DO NOT use <form><button></button></form> in this page, it can't be executed.

2. Create new 'page x'  and 'template x' file as a href link target in step 1 , processing code will be inside this template file, you can really flexible here by using get URL parameter in step 1, such ?id=something&status=something, example case is in invoice page, you can send different content email notification (unpaid vs paid) using one button.

Hope this can help somebody else trying to send mail in admin page edit.

  • Like 2

Share this post


Link to post
Share on other sites
33 minutes ago, pwfans said:

Hope this can help somebody else trying to send mail in admin page edit.

Thanks for the explanation! 🙂

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, pwfans said:

Hope this can help somebody else trying to send mail in admin page edit.

Thank you for posting this. Sounds like an approach I could have taken. I chose to solve this a slightly different way though.

  • Like 1

Share this post


Link to post
Share on other sites

On the module FieldtypeRuntimeMarkup I have error according to roles. As superuser I don't have any error but as contributor I have
trying to Get property on non-object and the html code in the field is displayed as source.

The line pointed at is this one

 protected function renderMarkup(Page $page, Field $field) {

                //if code field is empty return early
                if(!$field->runtimeFields) return;

                //locally scope $pages to eval()
                $pages = $this->wire('pages');

    ------>    $str = eval($field->runtimeFields);

                //since we are dealing with custom PHP code but also want to make sure that only markup is returned
                //if eval() returns anything other than a string or an integer, we throw an error (e.g. if an object or array is returned)
                if (is_string($str) || is_int($str)) return $str;
                //we need to check if we are in admin. Otherwise with an error, in the frontend the name of the the Fieldtype is returned if we echo out the field
                elseif($this->wire('process')->className() == 'ProcessPageEdit') return $this->error($this->_('Only strings and integers should be returned by your custom code! $

        }

Thank you

Share this post


Link to post
Share on other sites

The error is caused by the code you entered in the field settings. The eval line above just executes the configured code. So if you show us that code, it might be possible to pinpoint the exact issue.

  • Like 2

Share this post


Link to post
Share on other sites

Hi BitPoet,

Here is my code
 

$texte="";
$leslangues=array(1=>"fr", 2=>"de",3=>"en",4=>"es",5=>"he",6=>"it",7=>"pt",8=>"ru");
foreach ($leslangues as $langue => $langue_str){
$element = $pages->find("template=clef, langue=$langue, limit=1, sort=-id")->first()->title;
$nombre=(int) filter_var($element, FILTER_SANITIZE_NUMBER_INT);
if (!$nombre){
$nombre=1;
}
$texte.="<b>$langue_str</b> : $nombre, ";
unset($nombre);
}
$texte=rtrim(rtrim($texte),",");
return $texte;

Thank you for your help.

Share this post


Link to post
Share on other sites

Since the only line with property access is

$element = $pages->find("template=clef, langue=$langue, limit=1, sort=-id")->first()->title;

it seems that your selector returns no results, so the call to first() returns null and accessing the title leads to the error. Your contributor account may not have permissions on the template or the pages in question may be hidden or unpublished. Depending on the exact scenario, an additional selector is probably necessary (see the link for details).

  • Like 1

Share this post


Link to post
Share on other sites

What I don't understand is that the field is displayed anyway with the right data (each language has a number) but displaying the b tag.

Share this post


Link to post
Share on other sites

Thank you very Much BitPoet for your help, I was able to solve adding check_access=0 in my selector.

Great!

Share this post


Link to post
Share on other sites

Looking for help on this one. I have a RuntimeMarkup field in a template.

When I only return a string with no HTML markup, all is well. See image 1 where the RTM field is "Skills" and it's returning the title of an auto-generated FormBuilder entry with no HTML.

642448032_Screenshot2019-01-1618_09_33.thumb.png.2c41d0e50e8408dd4e92a2492fbb52d5.png

When I try to output more info from the FormBuilder entry & format it, the page CSS loses the plot. Not only are the UiKit3 styles ignored, much of the page CSS is broken too - note the Save Edit button and the stacked-rather-than-styled fields above it.

1230224745_Screenshot2019-01-1618_11_11.thumb.png.49a18a5986e9b397eb8c95169684841c.png

RTM CSS file is as default and all that's returned to the field is a valid string. I've even tried returning a valid HTML string with heading & paragraph tags to take FormBuilder out of the equation.

The output string is:

    <div>
      <h3 class="uk-h3">Skills</h3>
      <div class="uk-width-3-4">some other skill</div>
      <div class="uk-width-1-4">65%</div>
      <div class="uk-width-3-4">talking under water</div>
      <div class="uk-width-1-4">80%</div>
      <div class="uk-width-3-4">Yawning</div>
      <div class="uk-width-1-4">100%</div>
      <div class="uk-width-3-4">Balloon animals</div><div class="uk-width-1-4">80%</div>
</div>

Actually doesn't seem to matter what HTML tags or classes I enter, as soon as I do, the page CSS breaks. Believe me, I tried lots!

RuntimeMarkup is a @kongondo module

Any suggestions on where and how to fix?

PS: Text in the summary field comes from https://baconipsum.com/ - I like it spicy!

Share this post


Link to post
Share on other sites

@Chris Bennett ummn, not sure... went to PW Modules to get it - version 0.0.2

According to the Modules site & @kongondo's github site, I am.

There are a couple of modules that do similar. Please give me the URL to the one you used 😊

It's important to this site that I can "do stuff" in PHP/PW before outputting the string

Thanks

Share this post


Link to post
Share on other sites
1 minute ago, psy said:

@Chris Bennett ummn, not sure... went to PW Modules to get it - version 0.0.2

According to the Modules site & @kongondo's github site, I am.

There are a couple of modules that do similar. Please give me the URL to the one you used 😊

It's important to this site that I can "do stuff" in PHP/PW before outputting the string

Thanks

No worries Psy, give me a minute to look-see what I have and try to track down where I got it 

Share this post


Link to post
Share on other sites

@Chris Bennett thanks, a step in the right direction. Now can output direct HTML and it works fine but still problems when I try to construct the string from my function

Share this post


Link to post
Share on other sites

@psy,

I have moved your topic here since this is the support forum of the module 🙂

Apologies, I have not had the time to finish up on some new features and merger the dev version into master. 

11 minutes ago, psy said:

still problems when I try to construct the string from my function

I don't understand this. Please clarify:

  1. What function is this? Can we see the code please
  2. Where are you calling the function? Directly in RuntimeMarkup field settings or it is in a file and you are calling it using wireRenderFile() or $files?
  3. Errors in dev console?
  4. Can we see the output from the FormBuilder entry

Share this post


Link to post
Share on other sites

@kongondo thanks for chipping in 🙂 

My function is in a custom module and the code in the RTM field is:

$custom = $this->wire('modules')->get('CustomFunctionsTBR');
return $custom->getJobSeekerData ($page);

The function in CustomFunctionsTBR is:

    function getJobSeekerData ($page) {

        $skills = $this->formMultiple('jobseeker_skills', $page->user_id);
        $out = "";
        $out .= "<h3 class='uk-h3'>Skills</h3>";
        foreach ($skills['entries'] as $entry){
            $out .= "<div class='uk-width-3-4'>" . $entry['skill_name'] . "</div><div class='uk-width-1-4'>" . $entry['skill_level']. "%</div>";
        }
        return $out;
    }

Where $this->formMultiple function queries the FormBuilder entries for records based on a user id saved (but not displayed) on the page.

There are no errors in the dev console.

Output from var_dump just prior to returning $out in the CustomFunctionsTBR FormBuilder entry:

string(355) "<h3 class='uk-h3'>Skills</h3><div class='uk-width-3-4'>some other skill</div><div class='uk-width-1-4'>65%</div><div class='uk-width-3-4'>talking under water</div><div class='uk-width-1-4'>80%</div><div class='uk-width-3-4'>Yawning</div><div class='uk-width-1-4'>100%</div><div class='uk-width-3-4'>Balloon animals</div><div class='uk-width-1-4'>80%</div>"
string(355) "<h3 class='uk-h3'>Skills</h3><div class='uk-width-3-4'>some other skill</div><div class='uk-width-1-4'>65%</div><div class='uk-width-3-4'>talking under water</div><div class='uk-width-1-4'>80%</div><div class='uk-width-3-4'>Yawning</div><div class='uk-width-1-4'>100%</div><div class='uk-width-3-4'>Balloon animals</div><div class='uk-width-1-4'>80%</div>"

Seems to be rendering the output twice - have heard of this anomaly happening before, eg in certain repeater matrix situations...???

Or maybe it's late and I'm tired.

Any/all suggestions to fix are welcome.

Share this post


Link to post
Share on other sites

@psy,

Thanks for the info.

I have not been able to replicate this. I've used your example HTML strings and it works just fine. Page Edit renders fine. I even tried with invalid/broken HTML and nothing breaks; it works OK. 

3 hours ago, psy said:

When I try to output more info from the FormBuilder entry & format it,

I missed this earlier. What do you mean 'format it'?

I'm wondering if your string is maybe returning invalid HTML that somewhere trips the browser? Just guessing. Other than that, RuntimeMarkup's CSS and JS files are blank; they never return anything. I need to remove them actually as they don't do anything.

If all else fails, I'm happy to have a look around your install if that's possible.

  • Like 2

Share this post


Link to post
Share on other sites

@kongondo, thank you!

New day here and taking another look. I noticed in the code that even though I'm only calling FormBuilder to get the entries, all the FB scripts & css are loading into the <head>. Digging deeper to see if this is causing a conflict. Grateful for your offer to look around the code if I can't resolve it. Will keep you posted.

 

More: Yep, FormBuilder files seem to be the problem. Now to figure out how to use FB in admin area to get the entries without the scripts loading.

 

SOLVED: One of the things my custom function 'formsMultiple' did was render the form and add the output to the final returned array. Works great on the front end but not needed here. Made the form rendering optional in the 'formsMultiple' function and in the RTM code, said don't do it. End result is RTM field and rest of the admin page display as expected. Thanks for the help & pointing me in the right direction.

Edited by psy
Solved problem
  • Like 1

Share this post


Link to post
Share on other sites

I just had a very weird issue today... I'll try and describe it as best as I can:

I have a frontend search form (text search and filters), which used to work fine before I have installed and used the RTMU module. Today the following fatal error appeared:

Spoiler

Exception: Field 'offer_reference_chooser' is runtime and not queryable (in /home/sitecom/www/dev.webapp/site/assets/cache/FileCompiler/site/modules/FieldtypeRuntimeMarkup/FieldtypeRuntimeMarkup.module line 181)

#0 /home/sitecom/www/dev.webapp/wire/core/PageFinder.php(1268): FieldtypeRuntimeMarkup->getMatchQuery(Object(ProcessWire\DatabaseQuerySelect), 'field_offer_ref...', 'data', '%=', '')
#1 /home/sitecom/www/dev.webapp/wire/core/Wire.php(386): ProcessWire\PageFinder->___getQuery(Object(ProcessWire\Selectors), Array)
#2 /home/sitecom/www/dev.webapp/wire/core/WireHooks.php(723): ProcessWire\Wire->_callMethod('___getQuery', Array)

PW basically tripped over these lines:

public function getMatchQuery($query, $table, $subfield, $operator, $value) {
	// we don't allow this field to be queried
	throw new WireException("Field '{$query->field->name}' is runtime and not queryable");
}

Now, the strange thing is: I am carefully constructing my selector (only pages within parent 1041, with template 'project' etc.etc.). The only template that used the RTMU inputfield was NOT the template I was querying. I have used it in another template, along with a page-reference field. Now this page-reference field was configured to show template 'project' pages, and children of page 1041.

Now that I have deleted the inpufields / removed them from my other template, everything works fine again.

How can it happen that this inputfield is somehow interferring a PW selector / search?

For a second, I thought I could also just comment this line:

// throw new WireException("Field '{$query->field->name}' is runtime and not queryable");

but then again, I don't know what else I could possibly break somewhere else by accident.

@kongondo Do you have any idea? Did you ever run into similar issues?

SERVER DETAILS
ProcessWire: 3.0.124
PHP: 7.2.14
Webserver: Apache/2.4
MySQL: 10.1.35-MariaDB

InputfieldRuntimeMarkup: 0.0.2
TracyDebugger: 4.15.8
 

PS

The module worked fine for me otherwise! I have used it to add a link which opens a frontend-page in a modal:

return '<a class="pw-panel pw-panel-reload ui-corner-all ui-button ui-widget ui-corner-all ui-state-default" href="https://dev.webapp.mysite.com/somepage/" data-tab-text="Choose x y z" data-tab-icon="eye" id="proj_chooser" role="menuitem"><i class="fa fa-fw fa-search"></i> search / choose</a>';

 

Edited by dragan
added PS

Share this post


Link to post
Share on other sites
8 hours ago, dragan said:

Do you have any idea? Did you ever run into similar issues?

That's strange. I've never seen this.

I could do some testing but I'm finding it a bit hard to follow your setup (the project template, 1041, etc). If I could see an illustration of how everything connects plus your selector string as well as any code or setup you use for the page-reference field, that would help. Seeing what Tracy returns as a final selector would also be helpful.

Share this post


Link to post
Share on other sites

How do I get a reference to the repeater page, instead of the page the repeater is on?
$page->id returns the parent or containing page, rather than the repeater id.

[SOLVED]

$value = $this->hasPage->data['some_field'];

 

Share this post


Link to post
Share on other sites

Hey @kongondo - I am back working on that project that makes heavy use of this field and I just replaced the:

return $this->renderMarkup($page, $field);

with:

return true;

for the sleep, wakeup, and loadPageField methods and it is bringing calls to the render method back to just one, which is really important because it contains some heavy querying.

I am fine with this mod for my needs, but I wonder if you'd consider these as an option for when the module is only used in the admin. The render() method in the InputRuntimeMarkup file takes care of the actual rendering without all these duplicate calls to renderMarkup().

What do you think?

  • Like 3

Share this post


Link to post
Share on other sites
5 hours ago, adrian said:

I am fine with this mod for my needs, but I wonder if you'd consider these as an option for when the module is only used in the admin. The render() method in the InputRuntimeMarkup file takes care of the actual rendering without all these duplicate calls to renderMarkup().

What do you think?

Thanks for resolving the issue! I don't get the bit about only used in admin; do you mean use a condition to check whether in admin? If you tested and it works find in the frontend as well with your mod, that's great! If the mod affects the frontend, then we can do the condition check for admin. It's been a while since I looked at the module and the master branch is beginning to really lag behind the dev branch. If you can write some code for me here rather than a PR, I'll appreciate it, thanks.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Anssi
      A simple module to enable easy navigation between the public and the admin side of the site. After installation a green bar will appear to the upper side of the screen, containing a few navigation elements and displaying the PW version number.
      Heavily inspired by @apeisa's great AdminBar (Thanks!). I needed a bit simpler tool for my projects and as a result, this was made. Available on GitHub .

    • By Sebi
      I've created a small module which lets you define a timestamp after which a page should be accessible. In addition you can define a timestamp when the release should end and the page should not be accessable any more.
      Github: https://github.com/Sebiworld/PageAccessReleasetime
      Usage
      PageAccessReleasetime can be installed like every other module in ProcessWire. Check the following guide for detailed information: How-To Install or Uninstall Modules
      After that, you will find checkboxes for activating the releasetime-fields at the settings-tab of each page. You don't need to add the fields to your templates manually.
      Check e.g. the checkbox "Activate Releasetime from?" and fill in a date in the future. The page will not be accessable for your users until the given date is reached.
      If you have $config->pagefileSecure = true, the module will protect files of unreleased pages as well.
      How it works
      This module hooks into Page::viewable to prevent users to access unreleased pages:
      public function hookPageViewable($event) { $page = $event->object; $viewable = $event->return; if($viewable){ // If the page would be viewable, additionally check Releasetime and User-Permission $viewable = $this->canUserSee($page); } $event->return = $viewable; } To prevent access to the files of unreleased pages, we hook into Page::isPublic and ProcessPageView::sendFile.
      public function hookPageIsPublic($e) { $page = $e->object; if($e->return && $this->isReleaseTimeSet($page)) { $e->return = false; } } The site/assets/files/ directory of pages, which isPublic() returns false, will get a '-' as prefix. This indicates ProcessWire (with activated $config->pagefileSecure) to check the file's permissions via PHP before delivering it to the client.
      The check wether a not-public file should be accessable happens in ProcessPageView::sendFile. We throw an 404 Exception if the current user must not see the file.
      public function hookProcessPageViewSendFile($e) { $page = $e->arguments[0]; if(!$this->canUserSee($page)) { throw new Wire404Exception('File not found'); } } Additionally we hook into ProcessPageEdit::buildForm to add the PageAccessReleasetime fields to each page and move them to the settings tab.
      Limitations
      In the current version, releasetime-protected pages will appear in wire('pages')->find() queries. If you want to display a list of pages, where pages could be releasetime-protected, you should double-check with $page->viewable() wether the page can be accessed. $page->viewable() returns false, if the page is not released yet.
      If you have an idea how unreleased pages can be filtered out of ProcessWire selector queries, feel free to write an issue, comment or make a pull request!
    • By David Karich
      Thanks to the great Pro module "RepeaterMatrix" I have the possibility to create complex repeater items. With it I have created a quite powerful page builder. Many different content modules, with many more possible design options. The RepeaterMatrix module supports the cloning of items, but only within the same page. Now I often have the case that very design-intensive pages and items are created. If you want to use this module on a different page (e.g. in the same design), you have to rebuild each item manually every time.
      With this proof of concept I have created a module which adds the feature to copy a repeater item to the clipboard so that you can paste this item to another page with the same repeater field. The module has been developed very rudimentarily so far. It is currently not possible to copy nested items. There is also no check of Min/Max. You can also only copy items that have the same field on different pages. And surely you can solve all this more elegantly with AJAX. But personally I lack the deeper understanding of the repeaters. Also missing on the Javascript side are event triggers for the repeaters, which would make it easier. Like e.g. RepeaterItemInitReady or similar.
      it would be great if @ryan would implement this functionality in the core of RepeaterMatrix. I think he has better ways to implement this. Or what do you think, Ryan?
      Everybody is welcome to work on this module and improve it, if it should not be integrated into the matrix core. Therefore I put it for testing and as download on GitHub: https://github.com/FlipZoomMedia/InputfieldRepeaterMatrixDublicate
      You can best see the functionality in the screencast: 
       
    • By anderson
      Hi,
      Please take a look at this:
      https://templatemag.com/demo/Good/
      The upper nav bar, including dropdowns like "pages" and "portfolios", what do you call this whole thing? At first I guess it's called "dropdown nav bar", but seems not.
      AND of course, what's the simplest way/module to achieve this in PW?
      Thanks in advance.
    • By Sebi2020
      Hey, I'm new and I created a simple module for tagging pages because I didn't found a module for it (sadly this is not a core feature). This module is licensed under the GPL3 and cames with absolutly no warranty at all. You should test the module before using it in production environments. Currently it's an alpha release. if you like the module or have ideas for improvements feel free to post a comment. Currently this fieldtype is only compatible with the Inputfield I've created to because I haven't found  an Inputfield yet, that returns arrays from a single html input.
      Greetings Sebi2020
      FieldtypeTags.zip.asc
      InputfieldTagify.zip
      InputfieldTagify.zip.asc
      FieldtypeTags.zip