Jump to content

Can't upload image, get 404 error


Recommended Posts

Hello everyone,

I have a problem that I can't solve, when I upload an image I get a purple progress-bar with 100% but no image is uploaded.

When I look at the the console of my browser then I see this


And when I use network I see this


Now somewhere in the file InputfieldFile.min.js something goes wrong, but I have no idea how to overcome this.

I have detected inside this forum some solutions regarding upload problems, I have tried

adding '$config->uploadTmpDir = dirname(__FILE__) . '/assets/uploads/';' , did not work for me.

I also tried to place the oldSchool inside InputfieldFile.js, but since InputfieldFile.min.js is called up this won't work.

Please can anyone help me here?!!!

Link to comment
Share on other sites

Hello Adrian,

I can only tel this, when i click under [network] on the ?id=1033 i get a new window where i then click on the tab 'response'  and this shows me the html content of my 404 error page.

Well and Wanze, i am not sure what you want to say with the link.

The PHP version i am using is 5.3.27 and the always_populate_raw_post_data = ON.

I see that others set this to OFF or -1 and had no result, i am not able to change settings in PHP this has in the hands of my hosting service.

Now regarding this page i can say that under  /site/assets/files a map with 1033 exists and this has already 8 images files inside.
I set this up in my test environment and made a site-profile and installed this on the real website.

So people i hope you don't let me hang here and help me out? What must i do, where can i search?

Link to comment
Share on other sites

  • 2 years later...
On 27.07.2015 at 12:45 PM, tinyant said:

I have the same problem and what awkward is that I can edit all the other images that I have uploaded when my website was on my localhost. Now it is on godaddy server and If i want to add a new child, it adds the child but I can't upload and image. The file is there, the image is also in the folder, but the page returns 404 Not Found Error for some reason. I tried  to set always_populate_raw_post_data  to -1 

But nothing really happened. It all stays the same. I would be glad if you can give me a hand on this.

Thank you in advance!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...