Jump to content
benbyf

Hosting recommendations

Recommended Posts

Hi, Sure this gets asked alot but I was wondering if people have any recommended services that they run PW on. Please provide your recommendations for:

Shared

VPS

Self hosted servers

PaaS / SaaS

I used to recommended Lcn.com but they no longer have a VPS which satisfies the PW minimum requirements :( so I cant use all the new goodness in the latest releases.

Share this post


Link to post
Share on other sites

We use DigitalOcean with a ServerPilot managed layer so you can easily add additional users and apps. Works great and we never had any outage or unexpected downtime and support from ServerPilot is really good.

  • Like 3

Share this post


Link to post
Share on other sites
I am running 4 sites with someHost. They provide excellent support, amazing performance and reliability. Plus, they also provide multiple locations, which let's me distribute the sites closer to the target traffic for better latency.

Edited by LostKobrakai
removed host url

Share this post


Link to post
Share on other sites

There is no room for Spam in this forum

https://processwire.com/talk/topic/10421-hosting-recommendations/#entry100267
https://processwire.com/talk/topic/10538-good-shared-hosting/#entry99787

2 posts only with no content anything related to Processwire

2 posts only (purposely) in hosting recommendations threads
Processwire View profile has been disabled
Same text Juliahans under alias Violet alias Adella alias Alienyoung
 

  • Like 1

Share this post


Link to post
Share on other sites

We use DigitalOcean with a ServerPilot managed layer so you can easily add additional users and apps. Works great and we never had any outage or unexpected downtime and support from ServerPilot is really good.

Might look into using that solution soon - failing that, I might start getting more serious about sysadmin and install my own distru on a VPS :/

let you know either way

  • Like 1

Share this post


Link to post
Share on other sites

Weighing in a bit late.

We're running things on DigitalOcean as well, with Ajenti and Ajenti-V as VPS manager. We run Processwire on Nginx. :)

  • Like 4

Share this post


Link to post
Share on other sites

I run 1 site on bluehost for a pretty simple blog and it runs great, and another on vpsdime (super cheap high ram vps). Vpsdime is a bit slow though, might just be my settings but I really feel like I am getting what I pay for even though I have 12gb of ram to play with. Up shot is I can cache about as lazily as I want as I never run out of ram :)

Might look into using that solution soon - failing that, I might start getting more serious about sysadmin and install my own distru on a VPS :/

let you know either way

I found the easiest way to get going was to use cpanel/whm for server administration, really takes the stress down a notch when you think about all of the ins and outs of linux server administration. Then look in to some tutorials on mysql settings tweaks and php settings:) I am just about to start learning how to go about deploying an nginx pw install with centos on a vps.

Weighing in a bit late.

We're running things on DigitalOcean as well, with Ajenti and Ajenti-V as VPS manager. We run Processwire on Nginx. :)

I had to look up ajenti but that sure look sweet, how was the setup in comparison to cpanel? Also if you the one who set up processwire to run with nginx what sort of settings are you running on it. I know it's outside of the scope of the op, but your setup sounds pretty slick. Are you using varnish with nginx?

Share this post


Link to post
Share on other sites

been using DigitalOcean with a ServerPilot for two months now and been working well, only down side is its not easy to host email, but trying to do less and less of that anyways

  • Like 1

Share this post


Link to post
Share on other sites

I can't recommend google apps for work enough if you are wanting to add email. One of the best business decisions I made for one smaller company that I support. 

  • Like 1

Share this post


Link to post
Share on other sites

true - i think the cost for most clients on top of hosting is a bit of a turn off though.

Share this post


Link to post
Share on other sites

Yeah I wouldn't recommend it for large organizations necessarily but $5 bucks a person for 40gb isn't bad for smaller applications. There is also a 1tb option for accounts with less that 10 users. Out of curiosity what are you using for your email system?

Share this post


Link to post
Share on other sites

cpanel and emails supplied by my old shared host LCN.com not sure what they were using, standard stuff i think

Share this post


Link to post
Share on other sites

been using DigitalOcean with a ServerPilot for two months now and been working well, only down side is its not easy to host email, but trying to do less and less of that anyways

I set up email on a new droplet today.

There's a little button for automagically setting up MX records for Gmail. Literally. One click.

  • Like 1

Share this post


Link to post
Share on other sites

Most of you seem to be in Europe, but for those in North America I highly recommend Knownhost (Dallas) for managed VPS or managed dedicated. Our organization's been with them for close to 15 months now and the specs are good, the pricing's competitive, and the support is phenominal (fast, competent, and never at additional cost).

Share this post


Link to post
Share on other sites

Most of you seem to be in Europe, but for those in North America I highly recommend Knownhost (Dallas) for managed VPS or managed dedicated. Our organization's been with them for close to 15 months now and the specs are good, the pricing's competitive, and the support is phenominal (fast, competent, and never at additional cost).

Certified hosting is a very good company who offers managed vps up to dedicated.

Don't laugh, but godaddy has managed and unmanaged vps plans that are actually good performers at reasonable prices. One bonus is a free ssl cert.

Share this post


Link to post
Share on other sites

For my personal projects I use these guys. I honestly wasn't expecting anything much from them as these "Unlimited Webhosts" never live up to their means. However I actually prefer these guys over the more premium hosting we use at work. The support is absolutely amazing an usually respond in 15 minutes.

I've used DigitalOcean before, but I much prefer the ease of use of managed hosting.  

Share this post


Link to post
Share on other sites

Well here is an interesting tidbit if you are looking to try out DigitalOcean. I signed up for a new account and just didn't give them a credit card and 4 days later they sent me a code for $10 to set up a server. 

Share this post


Link to post
Share on other sites

I just switched to Stablehost and it has been great! Really fast and script install of Processwire. Just my two cents!

Jim 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By franciccio-ITALIANO
      Hi, I must change server provider.
      I don't want rewtrite all page and articles, what must I do?
      I download a database copy on my pc, and now?

      Thanks!!
    • By rolisx
      Hi Guys,
      Just finished a website locally and wanted to upload it on the webserver of my customer. I got a server 500 error. Now, the guidelines of the hoster (world4you.com) does not allow "Options" in the htaccess-file. So, when I uncomment these:
      Options -Indexes
      Options +FollowSymLinks
      the site is visible, but the content won't show and no links are available. Not sure if I need the Symlinks-part but I guess I need a workaround for the Index-part. Can anybody help here? I need the website up and running asap....
      Thanks!
      Roli
    • By jploch
      Hi folks!
      For a website Iam working on I need to (pre)load a huge amount of images (100-500) from a folder in assets (wich I upload via FTP).
      To preload them I want to add them to the DOM inside a container, that I hide with css.
      This images will be use for a frame by frame animation (that animates with scrolling) so they should be loaded parallel and if the user clicks a cancel button, the loading should be canceled. (My website is using ajax to load pages with different animations, and the loading of the second animation waits till the loading of the first animation is loaded completly, wich I want to prevent). 

      I want to use ajax to do this, so I can cancel the loading with xhr.abort();
      Here is my code:
      var folder = '{$config->urls->assets}sequenzen/test/'; xhr = $.ajax({ url : folder, success: function (data) { $(data).find("a").attr("href", function (i, val) { if( val.match(/\.(jpe?g|png|gif)$/) ) { $(".preloader").append( "<img src='"+ folder + val +"'>" ); } }); } }); this will give me a 403 forbidden error.
      After some research I found out that I have to put a .htaccess in my assets folder.
      I also tried putting it in the sub folder "test", where the files are, but Iam still getting the error.

      Is there anything else Iam missing? Is there a configuration in PW i have to change to do that?
    • By sirhc
      Hi all,
      I got a Internal Server Error when accessing de /setup/fields in my back end...
      Also when i try to reach it through the page tree, i can't edit the 'fields' page, same error.
      I do modify a image field through the api, i don't know if that has something to do with it, below the code i use to upload an image through the api, I deleted the parts that are not important. If anyone can help me that would be great.
      To clarify; the code below works fine, my image and page is created as expected, the only thing is that I can't access my /setup/fields/ page in my CMS anymore due to the Internal Server Error.
       
       <?php              if($input->post->submit) {             $photoPage = new Page(); // create new page object             $photoPage->template = 'photo'; // set template             $photoPage->parent     = wire('pages')->get('/foto/'); // set the parent                          $photoPage->name     = urlBuilder($input->title_photo); // give it a name used in the url for the page             $photoPage->title     = $input->title_photo; // set page title (not neccessary but recommended)                          $photoPage->save();                              // next: process photo upload                          // Set a temporary upload location where the submitted files are stored during form processing             $upload_path = $config->paths->assets . "files/photos/";                          // New wire upload             $file_upload = new WireUpload('file_upload'); // References the name of the field in the HTML form that uploads the photo             $file_upload->setMaxFiles(1);             $file_upload->setOverwrite(true);             $file_upload->setDestinationPath($upload_path);             $file_upload->setValidExtensions(array('jpg', 'jpeg', 'png', 'gif'));                          // execute upload and check for errors             $files = $file_upload->execute();                          // Run a count($files) test to make sure there are actually files; if so, proceed; if not, generate getErrors()             if(!count($files)) {                 $file_upload->error("Sorry, but you need to add a photo!");                 return false;             }             //success                          //echo 'photos stored';exit;                                  $photoPage->save();             //$session->redirect($locationPage->url);         } else {      ?> <section class="add-location">     <div class="container">         <div class="row">             <div class="col-xs-12">                      <h2>Spot toevoegen</h2>                 <form id="add-form" action="" enctype="multipart/form-data" method="post">                     <input type="hidden" name="MAX_FILE_SIZE" value="<?php echo $max_file_size; ?>" />                                          <div class="col-xs-12 col-md-6">                             <label for="fileselect">Upload jouw foto:</label>                         <p>                                                          <input type="file" name="file_upload" id="file_upload" accept="image/*"  class="inputfile" />                             <label for="file_upload">                                 <span></span> <strong><i class="fa fa-upload" aria-hidden="true"></i>                                 Kies je foto…</strong>                             </label>                                                      </p>                         </div>                                                  <input type="submit" name="submit" value="Upload" />                     </div>                 </form>                  </div>         </div>     </div> </div> <?php } } include('./includes/foot.php');?>  
    • By panx
      Has anybody installed a server on a android tablet to run processwire?
      I found KSWEB (server + PHP + MySQL) for android.
      KSWEB includes:
      - lighttpd server v1.4.35
      - nginx v1.9.3
      - PHP v5.6.12
      - MySQL v5.6.19
      - msmtp v1.6.1
      - Web Interface v1.2
      - KSWEBFTP v1.0
      - scheduler
      Does it have everything what processwire need?
      Thanks in advance
×
×
  • Create New...