Jump to content

404 error on saving a page in processwire


naruttam
 Share

Recommended Posts

The Processwire version is ProcessWire 2.4.0 © 2015

When attempting to save edits to the page, instead of getting the pw success message, I get the 404 page not found page.  
This page in question cannot be deleted, moved, edited...nada.
Page edit takes me to: http://www.mydomain....e/edit/?id=5772
When I attempt to save the edits the address bar still says:
http://www.mydomain....e/edit/?id=5772 but it displays the 404 Page Not Found page and changes are not saved.

Also disabled Modsecurity on the server. Any ideas please

Link to comment
Share on other sites

What is your PHP version? 

If your hosting environment can support it, you should seriously consider updating your ProcessWire version.  The current stable version is 2.6.1 and it incorporates many outstanding new features/capabilities.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By Flashmaster82
      Hi i need some help to solve this. I need to save a specific value when saving a page
      $p = $pages->get('template=customer_project'); $p->location = "Hello world"; $page->save($p); This is my code right now in ready.php. location is my field "text field" inside template "customer_project". Right now when i refresh a page with the template it only populates one page? I want every page that has this field "location" to say Hello world and save it to the database? Don´t know if a hook is better..
       
      PLEASE HELP!!!
       
    • By gswoodman
      Hello all,
      I have recently installed ProcessWire as I am learning to develop my own personal website.
      The installation process was completed, pressed 'Login to Admin' and I am receiving a 404 error.
      I am using a GoDaddy Shared Hosting Package with Plesk installed.
      Does anyone have any experience with using ProcessWire on a shared hoasting package?
      Many Thanks.
    • By rolspace.net
      Hi Everyone
      I have a problem here. I have built a site with Processwire on localhost and then transferred to my customer's server. a) it's a windows server (unfortunately) and b) there is a domain-mapping for this site, the domain points to a folder of another domain. Sorry, I can't explain it any better, I don't really understand the different types of servers (why do they have to be different anyway...).
      My problem is, that I see the main website but not the admin page. Do I have to add anything to my .htaccess file?
      I also tried to include web.config file. Not .htaccess nor web.config file have an impact when changing its content. I really have no clue what to do!!
      Links: mcconnellacademy.ch, mcconnellacademy.ch/admin
      Thanks for any pointing in the right direction!
    • By Speed
      Hi Everyone, New here but not new to CMS and Template developing  . Early today, I've installed PW, it was successful, the result was flawless. But then, I realized I've encounter 404 error and was unable to go into admin. I've spend 4 hours going through troubleshooting guide following this link  http://processwire.com/docs/tutorials/troubleshooting-guide/page3  and I am not getting any luck, so I was hoping I could get some help from you so I can get started with PW
      First, the PW is running on localhost using MAMP 3.3.2 (free version).  The PW files is located inside MAMP/htdocs as subfolder called pwNew. So obvious inside htaccess the  Rewrite Base command should be 
      RewriteBase /pwNew (of course hashtags has been removed) if I did it right, then it didn't work for me!  So next, I went inside  /apache/conf/httpd.conf and  then changed... 'none' to 'All' 
       
      <Directory />     Options FollowSymLinks ExecCGI     AllowOverride All     Order deny,allow     Allow from all </Directory> Unfortunately, it didn't work for me.  I've confirmed twice... the mod_rewrite have been installed, up and running.
      Confirmation # 1 running mod_rewrite_test.php with this code below, 
      <?php if(in_array('mod_rewrite', apache_get_modules())) { echo 'mod_rewrite is installed.'; } else { echo 'mod_rewrite isn't installed.'; } ?> ...and then run it from browser

      Confirmation # 2 from phpinfo

      I really need your help and hope there are solution for it.
       
      Thanks in advance. 
    • By z0rk
      I've just installed the latest version of PW on debian 8 with apache2. The install went flawless; no errors. After the install completed I tried to access /processwire/ and failed with a 404 error. The home page of the site displays, but all links fail with 404 errors.
      Research suggests to edit .htaccess to make sure RewriteBase poinst to [path]/processwire/. I did that, but access to /processwire/ is still failing. I've also tried to enable AllowOverride All in the apache2 configuration file, but to no avail.
      Any suggestions?
      Thanks
×
×
  • Create New...