Jump to content

Search the Community

Showing results for tags 'login'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to ProcessWire
    • News & Announcements
    • Showcase
    • Wishlist & Roadmap
  • Community Support
    • Getting Started
    • Tutorials
    • FAQs
    • General Support
    • API & Templates
    • Modules/Plugins
    • Themes and Profiles
    • Multi-Language Support
    • Security
    • Jobs
  • Off Topic
    • Pub
    • Dev Talk

Product Groups

  • Form Builder
  • ProFields
  • ProCache
  • ProMailer
  • ProDrafts
  • ListerPro
  • ProDevTools
  • Likes
  • Custom Development

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 82 results

  1. I didn't have time to look into the code, so I have to ask here: is there a limit for the password length? I'm using LastPass and wherever it's possible I use ridiculously long passwords. And so I did in PW for an admin password. After a logout I couldn't log in again. I managed to do that only after setting the pass to something shorter than 50-chars. I see no reason why the passwords could have been limited (as they're hashed anyway), so that totally might be something on my end (or LastPass). But, just in case, I thought it's worth mentioning here as a potential issue.
  2. Hi, I've just set up a client area with ProcessWire based on Ryans step by step guide here - It's pretty much identical, client areas are rendered depending on the users name. This means I can only have one login per client since users names must be unqiue. Often there's time where I have multiple contacts for one client and ideally I'd like to create a user login for each person involved. One login per client works, but ideally I'd like a unique login based on their email address. Is there a way to allow users to login using their email address and using a users name more than once? No worries if this isn't acheivable, I'm extremely happy with PW and have been very impressed at how easy it is to use. To all those involved, great work! Cheers
  3. I'm working on a project where I've got about 500 members. These members each have their own page with fields that they can edit and others that they can only view, all these member pages are under a parent page (members). Each member's page is bound to the user's profile using a pagefield in the user profile. I would like to have a login form on the sidebar where members log in from the front end and are immediately redirected to their particular page. I plan to use Fredi module to allow them to have front end editing access for their page. I don't want them to access the backend at all. All suggestions welcome. Thank you
  4. Hi guys, I'd like to center the admin login form. Here's how it is now: http://api.drp.io/files/5442717971fe5.png Any suggestions on how to center it? I've tried to do it but it broke all the responsive layout... I guess my css skills are a bit rusty...
  5. Hi. I installed PW as indicated wizard. When I click the button 'Login to admin' shows me a 404 error. What can I do?
  6. Hey guys, I'm new to PW. I'm trying to make a website where my clients can signup/login and set up their profile. Also, their customers have to be able to signup/login and view their profile. Basically, i have clients that will login and set up their own information in the website. Details included will be something like company name address contact info product image product description price Once my clients log in and input this information their customers can go to the client's web page and view the information and purchase items. So i basically need to know how to set up the users so that: clients can sign up and input their information which will output to a web page customers can log in and see the clients information where they can purchase items is there a module that caters for this already? Does the PW database cater for this? Any information on how to do this would be greatly appreciated! Regards, Nick.
  7. I'm getting reports from a client that PCs running IE8 & 10 on an internal network with ChromeFrame plugin installed won't stay logged in to a site that is set up with all the content behind a login form, i.e. on the front-end, not logging into the control panel. Disabling the plugin in the browser makes the problem go away. So does updating .htacess from <IfModule mod_headers.c> Header set X-UA-Compatible "IE=edge,chrome=1" <FilesMatch "\.(appcache|crx|css|eot|gif|htc|ico|jpe?g|js|m4a|m4v|manifest|mp4|oex|oga|ogg|ogv|otf|pdf|png|safariextz|svg|svgz|ttf|vcf|webm|webp|woff|xml|xpi)$"> Header unset X-UA-Compatible </FilesMatch> </IfModule> to <IfModule mod_headers.c> Header unset X-UA-Compatible </IfModule> This seems to have solved the issue but I thought it was worth mentioning here anyway.
  8. Hi Forum, weird behavior on one of my new websites: The site is already on the live server since days and I've created 5 users out of which one can't log in: "request aborted because it appears to be forged." Even more strange: I can log in with the users credentials and the same browsers, no problem (I'm of course at my desktop and not at my users office). The user swears that he has used the right credentials. I've gone through the relevant discussion but it wasn't of much help as this case is somehow different. I suspect the cheap semi-professional hosting company that the client has chosen against my advice - but that leads nowhere. I have to debug my own installation first anyway. Any ideas? Thanks EDIT: The client just reports that he can log in with browser in privat mode.
  9. Dear ProcessWire-Community, first of all I want to apologize for my weak english. I'm german and will try my best, but I hope you can forgive me if I missspell something or can't explain it in the right way. Further I want to point out, that in the last few weeks I've become a big fan of the ProcessWire CMS. The free structure with no useless functions and the great community made this CMS to one of my favourite CMSs. And that's the reason why I would like to ask for your help. I'm developing right now an medium-sized website and for this website I'm using the Template Twig Replace-Module. This module is great for saving lots of PHP-syntax, but is also very strict when you code wrong. For this website I want to implement an search and front-end-login-function and even though there are great tutorials for those functions available in PHP, I don't know how to translate those functions into the Twig-syntax. For the front-end-login-function I would like to try out this script. And for the search-function I would like to use the function from the search.php-template file, which is available when you first download ProcessWire. Now here is my question: Would somebody of you like to help me translate those functions into the Twig-Syntax or could someone explain to me how to use PHP-functions within the Template Twig Replace-Module. I know this is a lot to ask for and that this is a ProcessWire-forum and not a Twig-forum, but you would help me a lot. Sincerely, Andreas
  10. Since upgrading to the latest dev branch, I can only login to the backend with a user having the 'superuser' role. To test this I created a new role: 'test' and ticked every box, giving it full permissions. I then created a new user with just the role 'test' and tried to login. I just get the error message: "TemplateFile: You don't have permission"
  11. So, I was looking to implement the remember me for the login. I didnot find a module for that. The functionality will be some token saved on the user side, and on the first request make the user authenticate if he/she has the token with the request. So the question is what will be the first hook, which will be called, so I can implement the hook to add the implementation. Do you have any insights on the same?
  12. Is it possible to block another user from logging in when someone else is logged in already? The reason I am asking this: I'm setting up a test site for prospective clients. I have arranged it so the site gets set back to the original state every time someone logs in (DB gets restored from a backup copy). If someone else tries to log in at the same time though, things get messed up and have to reset things manually. So I would like to make it impossible to log in if someone else is logged in already and show a message to that effect. My problem is I haven't figured out how to detect if another user is logged in before logging in. (I am using the PageEditSoftLock module, but for this it is not the right thing, even with the hard lock turned on. I need to keep other users from logging in, not just from editing pages.)
  13. Dear all, A beginner here. When I went to this link:http://processwire.com/api/user-access/ to find out how to make login/ logout pages, nothing showed up. Any tutorial regarding this topic for guidance? I'd like to have two different groups of users and each goes to certain different pages after login. When they are logged out, both can see some general pages. Probably there is a very basic answer but I am not an advanced web programmer. Help me out, please Thanks
  14. **** UPDATE *** nevermind. seems to be an issue with my server/php. by testing it on another server, everything runs as expected. thanks! ******************** Hey ryan! i ran in a very special problem today: i moved a page to another server. (Im using V2.3) everything is good, except: i cant login as admin - because there is a problem rendering the submitbutton... in ProcessLogin.module i get a strange error: "Fatal error: Call to a member function attr() on a non-object in /Applications/MAMP/htdocs/[...]/wire/modules/Process/ProcessLogin/ProcessLogin.module on line 123" this is caused by trying to add the submitbutton rendered by InputfieldSubmit.module.... BUT: if i uncomment 123: $this->submitField->attr('name', 'login_submit'); 124: $this->submitField->attr('value', $this->_('Login')); // Login form: submit login button and 134: $this->form->add($this->submitField); everything of the loginscreen gets sucessful rendered (but without a login button, which is... well.. unusable the module itself (version 100) is fine, and taken fresh from git.. (i'm running in the same problem using the password-forget module)
  15. Hello everyone, It seems that I managed to mess up my Login page. I tried to use a custom template for it and when changing the template, I got the warning, that the field «process» will be deleted. (I hope I remember this right …) Of course I ignored the warning and my custom template didn't work properly, so I changed back to the processwire admin template again. Since I logged out, if I try to log in, I see no form, but the message «This page has no Process assigned». Is there a way for me to get back in and fix the Login page?? Any help would be very appreciated and sorry for my carelessness … tron1000
  16. Hi, I've created a frontend login form and redirect to a site where I want to offer some PDFs for registered users. I uploaded the files to a fields called pdf_files und looped through them to show them on the site. No Problem so far, BUT: The direct URLs to the PDFs are public reachable. Is there a way to solve this problem? Many, greets, DV-JF alias, Jens.
  17. Hi, I'm new to Processwire and I have to say that after reading through your forum and some of your tutorials I have taken the plunge and installed PW and quite like the CMF/CMS that you have developed and congratulate you and your communities efforts to date. I have come up against a problem when trying to develop between multiple environments i.e. dev, staging, production. The problem I am facing is that after doing and ProcessWire 2.2.13 installation (without problems) on my dev environment and then I move the site to staging or another developers environment, when I try to login to the Administration area I get a error "Unable to generate password hash". I have tried to empty cache, both browser and physical files and still get the error message and I can't login to the control panel. My Staging environments is running Apache 2 and PHP 5.2.17 (can't upgrade to 5.3 or 5.4 due to another cms legacy issue) and my Dev environment runs on MAMP 2.0 with Apache 2 and PHP 5.2.17 also. I have checked AMP logs and can't see anything out of the ordinary there. Just wondering if I'm missing anything. Any help would be greatly appreciated. Cheers Sambo.
  18. This post is like these two but I've not been able to fix my problem reading those threads (perhaps partly because I don't fully understand some of the exchanges as they skip past things I am not familiar with). With debug turned on, when I try to login I am getting (domain and password substituted out): TEMPLATEFILE : UNABLE TO GENERATE PASSWORD HASH #0 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/PASSWORD.PHP(33): PASSWORD->HASH('MY-PASSWORD') #1 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/SESSION.PHP(310): PASSWORD->MATCHES('MY-PASSWORD') #2 [INTERNAL FUNCTION]: SESSION->___AUTHENTICATE(OBJECT(USER), 'MY-PASSWORD') #3 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #4 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('AUTHENTICATE', ARRAY) #5 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/SESSION.PHP(262): WIRE->__CALL('AUTHENTICATE', ARRAY) #6 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/SESSION.PHP(262): SESSION->AUTHENTICATE(OBJECT(USER), 'MY-PASSWORD') #7 [INTERNAL FUNCTION]: SESSION->___LOGIN('ADMIN', 'MY-PASSWORD') #8 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #9 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('LOGIN', ARRAY) #10 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/MODULES/PROCESS/PROCESSLOGIN/PROCESSLOGIN.MODULE(77): WIRE->__CALL('LOGIN', ARRAY) #11 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/MODULES/PROCESS/PROCESSLOGIN/PROCESSLOGIN.MODULE(77): SESSION->LOGIN('ADMIN', 'MY-PASSWORD') #12 [INTERNAL FUNCTION]: PROCESSLOGIN->___EXECUTE() #13 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #14 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('EXECUTE', ARRAY) #15 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/PROCESSCONTROLLER.PHP(194): WIRE->__CALL('EXECUTE', ARRAY) #16 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/PROCESSCONTROLLER.PHP(194): PROCESSLOGIN->EXECUTE() #17 [INTERNAL FUNCTION]: PROCESSCONTROLLER->___EXECUTE() #18 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #19 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('EXECUTE', ARRAY) #20 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/ADMIN.PHP(45): WIRE->__CALL('EXECUTE', ARRAY) #21 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/ADMIN.PHP(45): PROCESSCONTROLLER->EXECUTE() #22 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/SITE/TEMPLATES-ADMIN/CONTROLLER.PHP(13): REQUIRE('/VAR/WWW/VHOSTS...') #23 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/SITE/TEMPLATES/ADMIN.PHP(13): REQUIRE('/VAR/WWW/VHOSTS...') #24 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/TEMPLATEFILE.PHP(125): REQUIRE('/VAR/WWW/VHOSTS...') #25 [INTERNAL FUNCTION]: TEMPLATEFILE->___RENDER() #26 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #27 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('RENDER', ARRAY) #28 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/MODULES/PAGERENDER.MODULE(250): WIRE->__CALL('RENDER', ARRAY) #29 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/MODULES/PAGERENDER.MODULE(250): TEMPLATEFILE->RENDER() #30 [INTERNAL FUNCTION]: PAGERENDER->___RENDERPAGE(OBJECT(HOOKEVENT)) #31 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #32 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('RENDERPAGE', ARRAY) #33 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(293): WIRE->__CALL('RENDERPAGE', ARRAY) #34 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(293): PAGERENDER->RENDERPAGE(OBJECT(HOOKEVENT)) #35 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('RENDER', ARRAY) #36 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/MODULES/PROCESS/PROCESSPAGEVIEW.MODULE(97): WIRE->__CALL('RENDER', ARRAY) #37 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/MODULES/PROCESS/PROCESSPAGEVIEW.MODULE(97): PAGE->RENDER() #38 [INTERNAL FUNCTION]: PROCESSPAGEVIEW->___EXECUTE() #39 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(271): CALL_USER_FUNC_ARRAY(ARRAY, ARRAY) #40 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/WIRE/CORE/WIRE.PHP(229): WIRE->RUNHOOKS('EXECUTE', ARRAY) #41 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/INDEX.PHP(192): WIRE->__CALL('EXECUTE', ARRAY) #42 /VAR/WWW/VHOSTS/EXAMPLE.COM/HTTPDOCS/INDEX.PHP(192): PROCESSPAGEVIEW->EXECUTE() #43 {MAIN} So far I have: replaced /wire/ with a fresh 2.3 copy set /site/assets/cache/ plus all contents to 777 set /site/assets/sessions/ plus all contents to 777 installed a copy of PW 2.3 in a sub-domain and checked it can login OK (server environment check) and all OK I am able to update the site by updating locally and then export/importing the database. I would be grateful for any suggestions as to how I can solve this, thanks in advance for comments!
  19. I am new to PW and have been pleased with it so far, however it recently started to jump out of the admin editor back to the login screen. he Login Throttle then prevents me from logging back in for 60 seconds. This is very frustrating. I have two questions. 1. How to I change the Login Throttle so I don't have to wait 60 seconds? 2. This one is more serious. I have noticed in the error. log I get this message (over and over again) So I am assuming this is the reason the Admin editor takes me back to the Login screen. Can anybody give some guidance as to what to do? Here is the error message 2013-07-25 10:36:27 admin http://dwimar.com/estar/http404/ Error: Exception: Method Page::localUrl does not exist or is not callable in this context (in /home3/dwimarc1/public_html/estar/wire/core/Wire.php line 232) #0 /home3/dwimarc1/public_html/estar/site/templates/head.inc(116): Wire->__call('localUrl', Array) #1 /home3/dwimarc1/public_html/estar/site/templates/head.inc(116): Page->localUrl(Object(Language)) #2 /home3/dwimarc1/public_html/estar/site/templates/basic-page.php(8): include('/home3/dwimarc1...') #3 /home3/dwimarc1/public_html/estar/wire/core/TemplateFile.php(125): require('/home3/dwimarc1...') #4 /home3/dwimarc1/public_html/estar/wire/core/Wire.php(271): TemplateFile->___render() #5 /home3/dwimarc1/public_html/estar/wire/core/Wire.php(229): Wire->runHooks(Array, Array) #6 /home3/dwimarc1/public_html/estar/wire/modules/PageRender.module(250): Wire->__call('render', Array) #7 /home3/dwimarc1/public_html/estar/wire/modules/PageRender.module(250): TemplateFile->render('render', Array) #8 /home3/dwimarc1/public_html/estar/wire/core/Wire.php(271): PageRender->___r
  20. Hi guys just moved from 34sp servers to lcn.com ones and as always something had to go wrong... transferred the db and files and linked up, everything worked until I tried logining in - I can't, no errors on the front end. I was also having trouble uploding images on some of my other sites So im guessing its a permissions issue just wondering what it might be, whether i just need to do something on .htacess or whether my hosting providerings can help. I hate sys admin Please any help would be great, Ben
  21. Am seeing an error when failing with a login which I've never seen before. "Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Error has been logged." If login succeeds the page redirects fine but when I input an incorrect combination, rather than an else statement I get the above error. The code I'm using is: <?php $out = "<h6>Please login below</h6>"; if($input->post->username && $input->post->pass) { $user = $sanitizer->username($input->post->username); $pass = $input->post->pass; if ($session->login($user, $pass)) { $session->redirect("/"); } else { $out = "<h6>Sorry, your login credentials were not correct.</h6>"; } } ?> <?php include("./header.inc"); ?> <div id="login" class="content"> <div class="row"> <div class="large-5 columns"> <?php echo $out; ?> <form action="./" method="post"> <label for="username">Username</label> <input type="text" name="username" autofocus> <label for="pass">Password</label> <input type="password" name="pass"> <input type="submit" value="Login" class="btn grey"> </form> </div> <!-- /.large-5 columns --> </div> <!-- /.row --> </div> <!-- /#login.content --> <?php include("./footer.inc"); ?> EDIT: Just to say there are no errors in errors.txt
  22. I'm developing a site for a client in a private directory on my web host that is running wordpress. In the clients site, I have a members section that requires a login. I'm having trouble with the logout url which when called will go to the wordpress logout screen when called. This is what I have for code: <div class="login-message">Hello <?php echo $page->title; ?>. Welcome back. <a class="logout" href="?logout=1">Logout?</a></div> I know that it will be fine in a live site but I need to show this functioning as intended for the client. Does anyone have any experience or suggestions on how to resolve this?
  23. I've been testing out the multisite feature of processwire installing via option 1 in the docs. I managed to get everything working by following the first option which requires installing a new version of PW and copying the files over to a site-mysite directory. I'm now testing out the second option which just needs the site files copies to a site- directory and importing the DB from another installation using PhpMyAdmin. The installation worked fine but when I try to login to the admin the username and password I used from my clone site are not recognised. I thought the password would pull over from the SQL database. I'm sure this is something really simple but I'm scratching my head at the moment. Any ideas?
  24. Hi all, I would like to redirect the session after successful login for a specific role. I want to keep a specific role in the front-end most of the time and upon successful login, would like to redirect them to the front page instead of the Pages section in the back-end. How would you suggest hooking into the login function and redirecting that role upon successful login? I know I'll need to use $session->redirect(). Thanks!
  25. Hi Guys, have a site in a sub-domain /blog/ and moved it out to / and the site works but the admin section wont allow me to login, wondering if this is usual and if there would be any reason for this? I've moved the .htaccess file with the site and checked the password is correct in the database. Any help would be awesome, thanks
×
×
  • Create New...