Jump to content

Search the Community

Showing results for tags 'CKEditor'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to ProcessWire
    • News & Announcements
    • Showcase
    • Wishlist & Roadmap
  • Community Support
    • Getting Started
    • Tutorials
    • FAQs
    • General Support
    • API & Templates
    • Modules/Plugins
    • Themes and Profiles
    • Multi-Language Support
    • Security
    • Jobs
  • Off Topic
    • Pub
    • Dev Talk

Product Groups

  • Form Builder
  • ProFields
  • ProCache
  • ProMailer
  • Login Register Pro
  • ProDrafts
  • ListerPro
  • ProDevTools
  • Likes
  • Custom Development

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. Having some issue with getting an iframe to save on a CKeditor text field (2.5.3). Things I've done to explicity allow it: - added "iframe[*]" to extraAllowedContent - added "IFrame" to the CKEditor toolbar - turned off CKEditor ACF - switched the field's "Content Type" from "Markup/HTML" to "Unknown" When pasting in my iframe code (it's a Vimeo embed code), CKEditor shows the iframe placeholder, but after saving the page, it's stripped out. For testing, I tried adding a simpler iframe using CKEditor's iframe toolbar button, but that also gets stripped out after saving. Anyone experiencing this, or have iframes working with their field?
  2. Greets I'm using the dev-build of PW for one of my sites (obviously will upgrade to 2.5 when released). I'm not a huge fan of the default CKEditor skin, and would like to use the office2013 theme instead. How would I go about doing that? Update I have tried adding a skins directory in site/modules/InputfieldCKEditor and loading the skin via config.js, but it looks for the skin in the wire/modules/Inputfield/InputfieldCKEditor/ckeditor-4.4.3/skins directory... Any way to change that? Update (again) This works, but isn't so elegant: ../../../../../../../site/modules/InputfieldCKEditor/skins/office2013 Surely one could make it so that it looks in both the `wire` and `site` directories for skins?
  3. I used CKEditor on a project and it seemed to go well, then I upgraded it and it started manipulating my DIV tags. For example, if I have a field where I had something like this: <div class="video-container"><iframe allowfullscreen="true" frameborder="0" height="360" src="//www.youtube.com/embed/ffffffffffff" width="480"></iframe></div> <p>New paragraph appears here.</p> This was fine with the prior version (I have both ACF and HTML Purifier turned off). But now something like this happens: <div class="video-container"><iframe allowfullscreen="true" frameborder="0" height="360" src="//www.youtube.com/embed/ffffffffffff" width="480"></iframe> <p> </p> <p>New paragraph appears here.</p> </div> My ending DIV tag gets moved to the end and an extra P tag gets inserted. Any ideas? Thanks, Matt
  4. Hi, I´m using CKEditor as an inline editor on the front-end. Now I need to call the ProcessPageEditImageSelect dialog when the CKEditor image button is pressed, just like when using the editor in the back-end. (Right now the standard CKEditor image dialog comes up.) Does anyone know how to integrate ProcessPageEditImageSelect here? Thank you!
×
×
  • Create New...