Jump to content

pmichaelis

Members
  • Posts

    58
  • Joined

  • Last visited

Posts posted by pmichaelis

  1. Hey everybody,

    I just uploaded a small textformatter module for wrapping tables with a div container in order to display responsive HTML tables in the frontend.

     

    TextformatterWrapTable

    Processwire wrap table module is a textformatter module for processwire CMS/CMF. It is wrapping markup tables with a div container.
    wrapping tables with div container simplifies the process of displaying responsive tables in the frontend.

    The css classes for the wrapper and the table are configurable.
    .table-responsive / .table

    by default the module produces the following markup:

    <div class="table-responsive">
    <table class="table">
    ...
    </table>
    </div>

     

    Link to Repository
    https://github.com/pmichaelis/TextformatterWrapTable

     

    • Like 7
    • Thanks 2
  2. Hey,

    I searched the forum, but I couldn't find any post with a topic of the problem that I am facing with the module. 

    I setup multilingual menues nd have different roles which have the menu-builder permission. As soon as Editors save a Menu, the custom title translations of the menu are gone. Menu Item titles of the default language are editable as a non-admin user, but all other language titles are ignored / deleted on save.

    Are only admin users allowed to edit title translations?

    Thanks for a short hint on that.

  3. Hey,
     

    I keep getting errors when I try to visit the upgrades admin page.
    I thought it was a memory limit problem and increased the memory, but I still get the errors.
     

    /processwire/setup/upgrades/	
    Allowed memory size of 134217728 bytes exhausted (tried to allocate 4096 bytes) (Zeile 1266 in /var/www/htdocs/wire/core/WireHttp.php)

    Any hints? Never had problems with the upgrade module.

  4. 5 hours ago, thomasaull said:

    @pmichaelis If the error is thrown in line 131 it's likeley there is an error with the JWT Authorization. Maybe the Token you're submitting is not valid, maybe something else. Hard to tell with the little information you provided.

    @thomasaull It seems that the authorisation headers are not present.

    Added the following line to the htaccess:

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    auth headers are stored in following variable

    $_SERVER['REDIRECT_HTTP_AUTHORIZATION'];

    Please don't ask why.

  5. Hey everyone,

    I did see, that other users were struggling with the problem, that there are no Markers displayed in the frontend, but I could not find any replies to that problem. 
    If I render a map, the coordinates are correct, but the marker icon is not displayed. It displays in the backend, but not in the frontend, also if if but the path to a custom image in the map options. Nothing. 
    Does anyone have the same problem?

    Thanks for any hints

  6. The jwt auth mechanism is producing errros on a live system.
    I allready looked for "Wrong number of segments", installed the module again, but the error is still there.  Any hints on that?

    DATUM/ZEIT BENUTZER URL TEXT
    vor 2 Minuten
    2019-03-29 13:22:58
    api /api/v1/items Error: Exception: Wrong number of segments (in /cms/site/modules/RestApi/Router.php line 131). File: /cms/index.php:64
  7. Hey Thomas,

    I had some issues yesterday with the jwt-authorization. On a local development server (vagrant, ubuntu, apache). The authorization headers were empty. Therefore the getAuthorizationHeader method in Router.php returned null and the token was not returned. I made a small modification to the method and it works for me. Perhaps it is not the cleanest way, but it's ok for now. Just to let you know.

     

    // apache
    if (strpos($_SERVER['SERVER_SOFTWARE'], 'Apache') !== false) {
    	foreach (apache_request_headers() as $key => $value) {
    		$headers[strtolower($key)] = $value;
    	}
    }
    else {
    	foreach ($_SERVER as $key => $value) {
    		$headers[strtolower($key)] = $value;
    	}
    }

     

  8. Hey,

    Thanks for that  module.

     

    in the module description it says:

     

    Authorization: JWT

    To use JWT-Auth you have to send a GET Request to http://yourhost/api/auth with two parameters, username and password. The API will create and return you the JWT-Token which you have to add as a header to every following request:

     

    Actually I think it has to be a POST Request. In the "DefaultRoutes" the Route is defined like this.
     

    ['POST', '', Auth::class, 'login', ['auth' => false]],

     

  9. 10 hours ago, Macrura said:

    it always works for me – did you add a general-settings permission and then add that permission to the role you want to have access to the settings? I will also check this on my last install to double check, but yes, it is supposed to work, that's why the module was re-written as a split module with the process.

    Ah, ok. Sorry, I used an older version. But upgrading seems impossible due to requirements ... 

  10. Hey there,

     

    Great module. Thanks for the functionality.

    I am using checkboxes of a multi-lang page reference field in the subscription form and I was wondering if multi-lang fields are supported by default, because the checkboxes are not translated. The Label of the field is translated correctly, but not the rest.

    Thanks for some information.

  11. Wanted to let you know, that I had some issues with AOIM running php 7.

    Error messages were generated because of non well formed numeric values.
    Maybe the issues are bound to my hosting environment. The following changes resolved them

    Changend line 775 in /site/modules/AllInOneMinify/lib/cssmin.php to:

    return intval($size);

    Changed line 713 in site/modules/AllInOneMinify/AllInOneMinify.module to

    $_timestamp = intval($_timestamp . $file['last_modified']);

     

    • Like 1
  12. 11 hours ago, Robin S said:

    Not in this fieldtype as it stands because it only has a single inputfield. But you can create other fields for the purpose and add them to your template, maybe grouped inside a fieldset together with the Assisted URL field. Text fields for title and rel, and maybe a Select Options field would be good for target.

    Ok, thanks for the reply. I was just wondering, because the modal dialog keeps all these options. An altnernative would be to store the data (url, title, rel, target) as json in order to have them.

  13. On 8.3.2017 at 0:34 PM, pmichaelis said:

    Hey,

    thanks for that module. 

    Maybe I missed something, but how to get the propoerties, like target, title, or rel in a page template?
    Are these values stored anywhere?

    Thanks for help.

    Sorry, that I need to post my question again. Is there a chance for storing these values to the db?

×
×
  • Create New...