$config->version() method

Check if current ProcessWire version is equal to or newer than given version, or return current version

If no version argument is given, it simply returns the current ProcessWire version (3.0.130+)

Available since version 3.0.106. with no-argument behavior added in 3.0.130

Example

if($config->version('3.0.100')) {
  // ProcessWire version is 3.0.100 or newer
}

Usage

// basic usage
$bool = $config->version();

// usage with all arguments
$bool = $config->version(string $minVersion = '');

Arguments

NameType(s)Description
minVersion (optional)string

Specify version string if you want to compare against current version

Return value

bool string

Returns current version if no argument given (3.0.130+), OR boolean if given a version argument:

  • If given version is older than current, returns false.
  • If given version is equal to or newer than current, returns true.

$config methods and properties

API reference based on ProcessWire core version 3.0.234

Latest news

  • ProcessWire Weekly #510
    In the 510th issue of ProcessWire Weekly we'll check out ProcessWire 3.0.236, introduce a new third party module PageFinder Depth from Robin Sallis, and more. Read on!
    Weekly.pw / 17 February 2024
  • Using date range fields in ProcessWire
    This week we'll take a detailed look at the newest addition to the ProFields set of modules: the Date Range Fieldtype and Inputfield.
    Blog / 24 November 2023
  • Subscribe to weekly ProcessWire news

“The end client and designer love the ease at which they can update the website. Training beyond how to log in wasn’t even necessary since ProcessWire’s default interface is straightforward.” —Jonathan Lahijani