Requirements

Before installing, please double check that your server meets the following minimum requirements:

  • A Unix or Windows-based web server running Apache (and others, see next section)
  • PHP version 5.3.8 or newer with PDO database support (PHP 5.5+ preferable)
  • MySQL or MariaDB, 5.0.15 or greater (5.5+ preferable)
  • Apache must have mod_rewrite enabled (when applicable)
  • Apache must support .htaccess files (when applicable)
  • PHP's bundled GD 2 library (ImageMagick also supported)


Installation from ZIP file

Download the latest version of ProcessWire (ZIP file).

Unzip the ProcessWire installation file to the location where you want it installed on your web server.

Load the location that you unzipped (or uploaded) the files to in your web browser. This will initiate the ProcessWire installer. The installer will guide you through the rest of the installation.


Installation from GitHub

Git clone ProcessWire to the place where you want to install it (from the command line):

git clone https://github.com/processwire/processwire.git

Load the location where you installed ProcessWire into your browser. This will initiate the ProcessWire installer. The installer will guide you through the rest of the installation.


Installation with Composer and Packagist

ProcessWire is available from Packagist and can be installed using Composer by typing the following from the command line:

composer create-project processwire/processwire

If you prefer, you can pull ProcessWire into an existing project (which will place it into the /vendor/ directory):

composer require processwire/processwire


Other installation options

See our download page for additional download and installation options.